Change track speed

Hi, I’ve used the effect speed, the effect tempo and the project rate. Most of the time it is fine, but something keeps happening that makes me furious hehe

If I change the speed of a track to align the beats with another, in the process, I sometimes change it so that it’s a little faster. Fine, no problem, i’ll change it back a bit and they will align.

Not fine, sometimes i’m back and forth, any change i make either way doesn’t make any difference.

The only solution, is changing the speed for different bits at a time…

I’m using Vista.

Your topic title says “Change track speed”, but the “Change Speed” effect is exact, so I guess you don’t mean that.
As it says in the manual (


Change Tempo is a time-stretching effect, because it defies the normal expectation that reducing the speed of the audio (thus increasing its length) will reduce the pitch and vice versa. As with any time-stretching effect, some audible distortions will be expected at more extreme settings.

Due to weaknesses in its algorithm, Change Tempo can remove a very short length of content from the start or end of the selection, or not stretch the end of the content to the end of the selection when slowing down. Both of these symptoms may leave a short silence at the end of the resultant selection. Therefore while fractional values up to three decimal places are supported for BPM changes and up to two decimal places for length changes, the resultant stretch length may have lesser accuracy.

To avoid this problem, you can use Effect > > Sliding Time Scale / Pitch Shift… > instead, setting initial and final tempo change to the same amount.

Does that help?

The next version of Audacity will have a “High Quality” setting that uses the same algorithm as “Sliding Time Scale / Pitch Shift” and so can produce tempo stretching to an exact length.

Oh my god i can’t believe the schoolboy error i’ve made. When changing the speed of a track in ‘change speed’, it does it automatically for you next time you click on it. Then i’m changing it, what a gorm i am!!!


BTW, can it be sorted so that it doesn’t change automatically?

What exactly are you trying to do?

Effect - change speed - it gives you current length, let’s say 3.00, then new length will say something different, even if you haven’t changed anything. How can I have it that either the new length is the same or nothing at all?

Thanks for your help.

The effect remembers the last used % change. If you want a different % change then you have to set the % change that you want.
You can reset the % change back to the default (0% change) by clicking on the “Manage” button and then selecting “Factory preset > default”, though it’s probably quicker to just type “0” in the “Percent Change” box.