Change Tempo Bug

Windows 10
Audacity 2.4.2

In a long string of notes, sometimes I want to fix the rhythm of some notes that don’t sync with others playing at the time.
Eg, one note was too fast and the next note too slow. The note rhythms do not sync with other instruments in the passage this way.

If I select the shorter note and ‘Change Tempo’ by a -0.15 for instance, the note should get longer by a certain length, but it does not!
It gets shorter and then inserts a length of silence and some garbage (especially after some Ctl-R’s) equivalent to the proper (I think) length.

However if I Copy the selection and Paste it in a scrap track, ‘Change Tempo’ works fine and the proper length is generated and I can Copy/Paste that version back into the ‘too short’ original.

My way, the notes following move over for the longer changed note.
Audacity’s way is to keep the original length and squeeze the new note into the available space that the original note, had by compressing it down to a size that will fit.

I am a retired professional clarinet player and 26 year programming veteran.
I am a long time user of this great software.
Thank you for fixing this. It is extra time consuming to make it work, and probably an easy fix for a programmer.
[email address removed to avoid attracting spam]

Enabled the “High quality stretching” option in the Change Tempo effect.

Change Tempo and Change Pitch effects are much more complex than they appear. Audacity provides two different algorithms. The default usually provides reasonable results and is pretty quick, but it may create an echoey sound and the length of sound produced is inexact. The “High quality” algorithm usually produces very good results provided that the amount of stretch is not too much, and the length is more accurate, but it is a lot slower.
More info:

High Quality stretching has always been set - and being a programmer, I appreciate the difficulty if stretching without changing pitch. But it puzzles me that it works if I do it by hand, but the program makes it shorter, then fills in the blanks.
Any way, i have found a way that works for me. If the pitch, amplitude and tone color is steady, the wave is very uniform, so I can copy/paste by finding a section of similar wave shapes and duplicating them as many as I need to fill the time. There were pops when I first tried, but now they are seamless and I use that process all the time.

I’m not able to test on Windows at the moment, but for me there are no added gaps if I use “High quality”. :confused:

Works for me on Windows 10 as well.

I’d like to be able to reproduce the problem, but I need more details:
Are you processing a mono track or a stereo track?
How long is the selection?
What settings are you using in “Change Tempo”?

OK, I can see a definite problem here, especially when high quality is NOT selected.

  1. Generate 0.3 seconds of a 440Hz tone.
  2. Select the audio from approx. 0.1 seconds to 0.2 seconds
  3. Count the cycles between .1 and .2 (spoiler: there will be 44 cycles)
  4. Apply Effect > Change Tempo > -.15 percent change
  5. Count the cycles: 39, with 5 cycles of zero.
  6. Ctrl-R, and the problem gets worse.
  7. It only takes 8 repeats and there is no audio left at all! :open_mouth: :astonished: :confused:

I think that’s just a limitation of the SoundTouch algorithm. The algorithm is based on “synchronized overlap-add” (See: and is one of the main reasons that I added the SBSMS option to Change Pitch and Change Tempo.

I agree with steve, it’s all because of the SoundTouch algorithm