Change Pitch settings in chains are ignored

Audacity 2.1.1 via .exe installer
Windows 8.1 64-bit
(tested on two machines)

When I run a chain that uses Change Pitch, the Change Pitch settings are ignored and set to 0. For instance, I have a chain which applies Reverb, then step 2 changes pitch up three half-steps, then knocks the amplitude down -10 dB. As far as I can tell, Reverb and Amplitude are applied, but Change Pitch does nothing. If I Edit Chains, then manually re-set the Change Pitch settings to 3 half steps (18.9%), then save and run it, it works. If I close Audacity, start it again, and run the same chain, it will force the Change Pitch settings to 0 even though the chain details say 18.9%. I tried creating a Change Pitch preset for this, but there’s no difference.

There is nothing in the Audacity log about this, that I can see. I’ve searched Google and this forum and haven’t seen anyone discuss this yet.

I don’t know if any other filters are affected. Just to be safe, I re-configure my chains by hand every time I start Audacity… which almost invalidates the point of using a chain.

Thanks for the report.

Agreed, I will log it as a bug when I have time if it is not already there.


This is still happening in Audacity 2.1.2. This time I’m on Windows 10 64-bit.

BTW, this also happens with Equalization. Any chain that includes an Equalization step must be either manually edited and re-set prior to running it, or I have to run the Equalization effect manually and then run the chain. If I don’t do this, the chain will run Equalization with no settings, which gives the appearance of having done something, but in actuality it does nothing. Frankly, I would rather have it error out or even crash, so that I know it failed.

Thanks for the report. The reset of the Chain parameters won’t occur in the Audacity session if you don’t use the effect from the Effect Menu.

The Change Pitch parameters will reset to no change every time you restart Audacity because we don’t yet save the Change Pitch parameters.

I’ve changed the bug from being tested (DEVEL - FIX MADE) to REOPENED: Time had not permitted testing each and every effect. If you find any more effects whose Chain settings don’t persist, please reply here.