Chain completes but returns to original state [SOLVED]

I made an effects chain to batch process some spoken word audio recordings from conferences. A combination of noise reduction and various compression and silens reduction.

I run it, and the chain seems to run. I can see each of the effects processing and the changes taking effect. However then it just returns my back to the Apply Chain window, and the audio reverts to the original state (which is very obvious because the first step of the chain is Stereo to Mono, which is no longer applied, despite it visually have being applied as the first step).

I’m running 2.1.2 on macOS 10.11. I’ve also applied the terminal command “sudo xattr -r -d /Applications/Audacity/” to fix the issue with Nyquist plugins not appearing. Otherwise fairly generic.

I’m only using bundled in-built and Nyquist plugins. No other AU or 3rd-party plugins.

Any ideas or suggestions on how to resolve the issue?

Are you applying the Chain to the current project, or to audio files?
See if anything here helps:

Also perhaps attach the TXT file for the Chain, which should be in ~/Library/Application Support/audacity/Chains.
Please see how to attach files to forum posts.


Turns out the Chain wasn’t the issue, it was running the Clip Fix effect over the entire 1h15m audio file. Without that the chain runs fine (on my Current Project).

I’ll have to raise another thread/bug for the Clip Fix effect (which I realise isn’t really meant to run over a whole file, but I’m trying to devise an automated audio clean-up process for a group I volunteer with, for their spoken-word recordings).

Sorry for the newbie question, but is there I way I should mark this thread as solved?

We don’t have a proper method to do it. You can add [SOLVED] to the title of the first and last post, and then we could lock the topic. I’ve done that.