cdda frames correction

is there a way to retroactively (batch) correct the frame boundaries of (already) splitted wave-tracks to be cdda conform (75fps) within audacity?

I don’t know, but what are you trying to do? Maybe you shouldn’t split the file? Or, maybe you should re-join the files?

At the bottom of the Audacity window, you can change the time settings to display frames.

Your CD burning software will probably pad the file, making a full-frame at the end. (So there’s probably no need to do it in Audacity.)

…The only time I’ve given frames a 2nd thought is when making a cue sheet for a continuous/live recording. And in that case, I “manually” converted milliseconds (or 10ths of a second) for each track marker to frames.

thank you for taking time to answer.

well, of course i could join and resplit them, but isnt there a more elegant way to quickly make the already splitted waves cdda frame conform?

That’s how I would do it if I needed to.

In case you need to do this and you needed more information, Doug meant that you have to click the dropdown arrow to right of the digits in Selection Toolbar, and choose “CDDA Frames (75 fps)”. Then further to left in Selection Toolbar, choose one of the “Snap To:” options (if you are using an older Audacity version, Snap To is a checkbox). Then clicking or making a selection will snap to a CDDA frame.

As Doug said, this isn’t usually necessary, and it’s more awkward to do it with an existing file.


hm, that is very time consuming. i hoped, there is a quicker (batch) solution to it (not necessarily with the help of audacity)…

just for better understanding:

if i leave the splitted files as they are and burn them with padding activated, will the result be identical to post corrected tracks (with audacity)?

if so, the benefit of ‘correcting’ them is not given, as the cd will never be gapless for real, is it?

and therefore, rejoin + split is the only way?

If you have a continuous performance that must play continuously as the CD moves from one track to the next, the CD drive you are burning with must support Disc-at-once (DAO) as a first prerequisite. See Gapless burning.

If the CD burner pads silence to end at a frame then the result won’t be identical to using Audacity to set boundaries to CDDA frames, but the padding does not matter if it is not a continuous performance.

Audacity has no batch command to trim or expand to frame boundaries. You could double-click an existing WAV file with Snap To on then SHIFT-click at the end of the track might trim or expand, depending on the version of Audacity (you have not told us your version - see the pink panel at the top of the page). So you may need to zoom in and see exactly what is happening with each file. That’s why it is probably better to join and re-split with Snap To on, marking the track splits with a point label, then Export Multiple.


If your reason for splitting on frame boundaries is to achieve gapless playback from CD, then you probably don’t need to do that. Most modern CD burning software can produce gapless audio CDs without the user having to worry about frame boundaries (subject to the drive supporting DAO).

no problem, my drive supports dao (nopad) - it is a continuous performance, so gapless burning is needed.

just to recap, if i correctly understood (for future editing as well as correcting existing tracks (audacity 2.1.2):

  • choose one of the 2 CDDA Frames (75 fps) options and turn on snap to (next) in selection toolbar

  • editing (manual mark/cut/export or marking for multiple export) is now cdda conform

    in case you want to correct an existing track, just import it and then doubleclick the wav in the main window?

it is a continuous performance, so gapless burning is needed.

If you have the original non-split file you can use a [u]cue sheet[/u] to set the track markers, as long as your burning application supports cue sheets (I use ImgBurn).

thanks for the hint.

yes, i still have my original file and will try what you suggested.

also, i tried what gale had proposed, but could not get it working in audacity with the existing files?

We did tell you it was fiddly to do it that way. But you need CDDA frames set in Selection Toolbar and Snap To on even if you rejoin the files then Export Multiple by labels.


I think you’re making hard work of a simple task. I’ve made many gapless CDs that play perfectly continuously from one track to the next, and I’ve never bothered splitting on CDA boundaries, I just let the CD authoring application handle it by selecting the “no gap” option. Some more primitive CD authoring apps may require that the tracks end on CDA boundaries, but most modern CD authoring applications can do gapless CDs whether the tracks end on CDA boundaries or not.

I agree with Steve you should probably just try it without making new WAV’s split on CDDA boundaries.

But just for completeness, the double-click to select all disregards Snap To units. If after selecting all you zoom in at the end of the track ( CTRL + 1 then CTRL + } ) then hold SHIFT and click close to the end of the track, the right selection edge will contract or expand to a frame boundary. It is fiddly if you wanted it to expand because you would have to generate silence after the end of the track, which is probably not what you want. You can choose “Nearest” or “Prior” Snap To in current Audacity, but If you only have a checkbox for Snap To, you cannot choose and the behaviour varies between Audacity version.


@gale: ok, i will retry.

@steve: and so did i, and in some cases wondered about a little gap (but only from cd), even though i splitted them ‘correctly’ with audacity…

lately i used a different tool for burning, namely cdrecord. now comes the interresting part: i can not burn my waves with it, using -sao and -nopad… guess why :wink:
i need to set -pad in order to let cdrecord do the adjustment, the result is once more not gapless…

now you know why i am interrested in batch adjustment.

may i ask what burning tool you use, as it seems to give better results?

Last time I made any gapless CDs was with K3B (I use Linux).

Previously (years ago) I have used both Nero and CDBurnerXP to make gapless CDs. I stopped using Nero because it became too bloated, and I stopped using CDBurnerXP because I stopped using Windows. Probably more helpful to get suggestions from a regular user of Windows.

so k3b generated discs really never gave you any noticable gap on track change (even with nonconform cdda frames)?

that is very interresting. maybe i should give it a try, but basically it is just another frontend to cdrtools as well. i wonder which occult option it adds for burning :slight_smile:

@gale: finally i was able to correct the waves with audacity & cdrecord (simulate) does not complain anymore, thank you.

but i still need to listen to a burned disc to be sure about gaps.

just a quick question: is it possible to adjust the beginning of a track (not the end), as well?

So you are burning on Linux now?

The beginning of a track (time zero) should by definition be at at the start of a CDDA frame.


yep, i am on linux… (wrong section, i know… but this subject is not os specific anyways) :wink:

so i listened to the cd and the result sounds better with audacity corrected tracks this time.

i am really curious to know, why cdrecord’s padded tracks are not on par? shouldnt the result be somewhat identical?