Cause of blank section in middle of track?

I use v2.1.3 under Win10. Installed Audacity with .exe file (I think).
Problem: Sometimes after recording a mono track and editing sections of it, the track contains an unexpected blank section even though I didn’t (deliberately) separate the track into multiple clips and time-shift the clips independently.

In this case the initial recording was about 15 min long. I edited out (with Edit/Cut or the Delete key after highlighting material to be deleted) several brief sections starting at 0:00. Then found a blank section from 9:13 to 9:45, indicating that the material from 9:45 onward hadn’t moved left to fill the cuts as I’d expected all material rightward of any cut to do. When I highlighted this blank section and hit the Delete key, the material initially from 9:45 onward moved left to start at 9:13, but there was a thick vertical line at that point separating the material up to 9:13 from the material (initially from 9:45 onward) that just moved left. It may be relevant that in the initial recording, I stopped recording, then restarted recording with Transport/ Append Record at approx. 9:45 of the track.

This kind of thing – blank section mid-track after editing – has happened intermittently before but I don’t understand what makes it happen or not happen, and need to.

– What could cause blank section to appear from 9:13 to 9:45?
– After I deleted the blank section, why did the black vertical line appear and what does it indicate?
– Does Transport/Append Record automatically create a new clip?
– What kinds of attachment files does the Forum accept? I tried to attach a Word file with an illustrative screenshot of the Audacity project but the Forum doesn’t accept .doc or .docx file attachments.

No one responded to the previous iteration of this question. My apologies if the question is too ignorant but I’d really appreciate your help on it. Thanks.

My apologies if the question is too ignorant

Or the other option is nobody can figure out what happened.

I tried to take this upside down: if somebody paid me to make this happen, what would I do?

Beats the heck out of me. I got fuzzy pieces. It’s possible to construct an Audacity show from external files, not Audacity Personal Copies. So Audacity is constantly at the mercy of the external file system. That used to be the default and it used to drive people nuts. In that case, Audacity would go for the fragment to move it and it either wouldn’t be there, or the permissions would be scrambled.

The other possibility is Audacity cache system. Audacity keeps its working data in a cache system while it’s editing. If something happens to the connection to that cache, Audacity will be unable to update your edit.

We sometimes lay that at the feet of a Windows Virus Protection program. You can do local investigation by disconnecting your network and disabling your virus software. Did that help?

Having an intermittent problem is just the most fun you can have. Developers have a phrase “Moon Phase Errors.” Sometimes, then the moon is 1/3 waning on a month beginning with “J”, the error will occur.

If you can get it to fail reliably with some repeatable condition, post back, and check back for other postings.