cassette to mp3 not recognised

Mojave 10.14.6
Audacity 2.4.2
I hooked everything up and rescanned audio devices, found my device and successfully recorded a small amount of audio from an old cassette tape as a test. Then when i went to record a full song error code 9997 then 9986 i shut down restarted, disconnected then reconnected and my cassette to mp3 device has vanished, rescanned for audio devices but nothing, tried a different cable, nothing.Tried a different usb port, nothing. Went to system preferences/sound/input and my cassette to mp3 device flickers on and off the screen as an input device but will not appear there for more than a second or two.Please help.

Let me guess - one of these?

Do you have the receipt? Is it still under warrantee?

Yeah one of those, what a piece of junk. Already made arrangements to return it. Thanks anyway. Cheers.

There are some [u]component-type USB cassette decks[/u].

Or if you already have an analog cassette deck/player you can get a USB audio interface with line inputs or you can use a computer with a regular soundcard with line inputs. The Behringer UCA202 or UCA222 is relatively inexpensive ($20 - $40 USD) or there are higher-end audio interfaces with switchable mic/line inputs. (Those Behringer inexpensive interfaces don’t have a recording-level control which can sometimes be an issue if the signal is too hot and clips/distorts.)

Don’t buy a regular little “USB soundcard” because they only have mic-in and headphone-out.