Captcha driving me nuts!

I tried to save a draft of a lengthy reply (including 2 code sections) and each time I click save draft, I get a captcha presented.
Once I clicked my way through the traffic lights and cars, I see the dialog of “do you really want to save”, I say “yes” — and nothing is saved!!
Browser: FF 63.0.3

Workaround: if you are presented with a Captcha, go back & save a copy of your post, (“Ctrl”+“C”).
Then if after completing the Captcha your post is gone you can paste it back in, (“Ctrl”+“V”).

The only time limit that I can find enabled, is the “Maximum time to submit forms:”. That is currently set at 2 hours, which means that if spend more than 2 hours writing a post, the post becomes invalid. Is 2 hours not long enough?

I’ve looked further into the issue, and I think it’s because your IP address keeps changing. For security reasons, if your IP address changes, then the session expires. You are being challenged by the captcha when reconnecting.

Time limit - C’me on!
I log into the forum, read the last post and start typing away on a reply Then try saving a draft. All this takes about max 5 mins.

Also IP address is definitely not the reason (I’m right behind a router in a tiny private network):
I reduced the text I tried to save as draft line by line, until I arrived at the “code” below: If I try to save the text as it is (no matter if enclosed in code tags or not) I get a captcha. But as soon as I delete any one of these lines, save draft works OK!
And: I did this test on Chrome so I don’t run again into any Firefox add-on issues.
Can anyone reproduce this issue, using the text below?

;name "fade 'n cut"
;name "Set fade-out/-in times"
;control fti "Fade-in time"  real "seconds" 0.2 0.01 2
;;; define function "select", with 2 args, based on Audacity "Select:" macro
(defun select (start end)
            (>= next now))
        (list (first (nth (1- j) labels)) next))))

Double checking: trying to save a draft of this very post takes me to a captcha. As soon as I remove the code section, no captcha.
PS: It even wants a captcha as I want to submit this!
PPS: re time limit: max 30 min have passed since my login.

PPS: after I checked the box “I am not a robot” (new variant: this time without having to mark any funny jigsaw puzzle!) I had to wait for a while (with progress circle running and “attention! Cloudflare” in the tab of the browser) only to end up at a page with an error message “503 service unavailable, Guru Meditation XID 1254147341 Varnish cache server”
But when I checked back the thread, I found that my post had been submitted just the same.

PPPS: I edited an resubmitted my previous post: this time again a captcha (just a checkbox, as before) but only a very brief delay ("cloudflare…) until I got back to see it was accepted. So the 503 message was probably a transient error.

edit: this post got submitted with no extra hurdles

Please don’t be belligerent. Your first post said “a lengthy reply (including 2 code sections)”, so I looked for reasons why a “lengthy reply” might cause problems. In the absence of more precise meaning to “a long time”, a “time limit” somewhere is an obvious possibility. The fact that the forum software time-out settings are all at least 1 hour, and you have NOW said “max 30 min have passed since my login” and “All this takes about max 5 mins”, rules out this possibility.

But your IP address does keep changing.

Your account was registered from:
Your first post in this topic was sent from: xx.xx.xx.215
Your second and third posts in this topic were sent from: xxxx:xx:xxxx:xxxx:xxxx:xxxx:xxxx:968

It is looking unlikely that the forum software is causing the Captcha problem, but the server on which the forum runs is behind caches and security walls (including Cloudflare, as you have noticed), so it is possible that the Captcha is coming from the server security rather than the forum software. I shall ask the System Administrator to investigate (I only administrate the forum, not the server).


Do you see a Captcha that looks like this (below)?
If you do, please make a note of the “Ray ID” - this may enable the SysAdmin to trace the problem.


I have analyzed your activity and related CloudFlare events and made a change to our setup. We will be testing it. Please let us know if you find additional problems.

Sorry I didn’t mean to be rude - it was more of a sigh. I also thought about a timeout, but - if any - I couldn’t believe that forum SW like this should have a timeout that kicks people out even after a reasonably long time (some 30 mins), as typical posts in here could be quite lengthy in creation.

If this is the case, then I have no idea how this happens and how to control it. I’m on a vanilla VDSL plan from German Telekom and never had problems of that kind.

Thanks for checking. I will include my test code in here and see if it still throws the captcha.

;name "fade 'n cut"
;name "Set fade-out/-in times"
;control fti "Fade-in time"  real "seconds" 0.2 0.01 2
;;; define function "select", with 2 args, based on Audacity "Select:" macro
(defun select (start end)
            (>= next now))
        (list (first (nth (1- j) labels)) next))))

OK: preview and save draft didn’t have me go through captchas any more. Now on to submission…

No captcha any more - hooray!
Thanks a lot Steve and Buanzo for the quick reply and solution!
I’ll get back with the RayID (if available) here, in case this pops up again.