Can't write to plugins.cfg in Windows 7

I am using Audacity 2.0.3 in 64-bit Windows 7 Home Premium Service Pack 1.

Trying to use a new VST plugin which I’ve put in the plugins folder (RoVee.dll), but everytime I start Audacity I get an error message: “can’t open file plugins.cfg, access denied”

I’ve tried the following:

  • run Audacity as administrator
  • checked that plugins.cfg is not Read Only
  • taken ownership of the entire Users folder and its subfolders

The only thing that works is to login as Administrator (not “run as …”). Which is a real pain.

Any ideas?


I’ve answered this extensively on feedback@ so far.

To save duplicating answers, at the moment we are agreed that for whatever reason you need to log in as administrator before you can write to plugins.cfg (which is required to rescan for new VST plug-ins).

You have said that if you quit Audacity, then navigate in Explorer to plugins.cfg, make a copy of it (still with .cfg extension), then open the copy in Notepad, make a change and save it, Windows lets you do that without being logged in as admin,

Obviously you should not need to be logged in as admin to write to plugins.cfg, and it’s odd that you can edit the copy in Notepad and save it but Audacity won’t write to the original. Can you edit plugins.cfg itself in Notepad and save it (with Audacity closed)?


Thanks for your help Gale. I’ve finally fixed it!

I simply deleted plugins.cfg, created a new one with Notepad and everything works fine!

No idea what was going on.


Hi Chris,

Thanks for replying.

Was the new plugins.cfg you created empty, then Audacity could write to it?

Were you logged in as admin, or running Notepad as admin when you created plugins.cfg?


plugins.cfg was empty so I just created a new empty one. I was not logged in as Admin when I used Notepad. Go figure!