Can't use AirPlay speakers [SOLVED]

I want to use some airplay speakers with Audacity. Despite selecting then in the Sound Preferences panel, the output remains on the built-in speakers. When I selected the output menu in Audacity, the only selection is ‘Built-in Output’.

Any ideas how to get the output off the built-ins speakers?


OSX v.10.11.4
Audacity v.2.1.2

Have you tried Transport > Rescan Audio Devices? You need to use that if you connect external devices after Audacity is open.


Thanks but the output menu still only has the one ‘Built-in Output’ value.

Oh, I bet I know what happened. The speakers are not sound devices, they’re network connections.

Apple (upper left) > System Preferences. See if you can find the speakers. I bet they’re under Network Sharing or BlueTooth, not Sound.

Your AirPlay instructions should tell you what happened.


I see the speakers I want to use in Sound>Output. It simply has no impact on Audacity’s behavior. I don’t see them in Network and wouldn’t in Bluetooth as they’re not Bluetooth devices.

And what brand/model are these Airplay speakers? Airport Express?

I only use Airplay with iTunes and it works. Can"t remember if I’ve ever tried it with Audacity. I’ll test later, as I have to run now…

I’ve attempted this with both my iHome iW1 speaker and some computer speakers connected to an Airport Express. I sometimes use these as outputs for my Mac (outside of iTunes).

I’ve tried it with an Airport Express, Audacity 2.1.2 on Mavericks and it works as it should here.

So I’m not sure what your problem is. Did you try without the iHome speakers connected to your network?

Have you tried restarting everything (including the router)

What make/model is the router? An Apple router?

Airplay uses Rendez-Vous, an Apple discovery protocol to find the Airplay devices. Sometimes, this gets confused, because two devices have the same name. Your iHome speaker doesn’t have the same name as another device on the network, by coincidence?

Not sure what the point of this would be. Can you elaborate? FYI, this is an issue for any AirPlay speakers on my network.


Airport Extreme

No name collisions. FYI, I often have to restart the iHome which can’t be found when I attempt to use it through iTunes.

Thanks for hanging in there with me!!!

OK, so since I last worked on this issue, I attempted (and failed) to install SoundFlower ( I eventually uninstalled it using the included AppleScript. Anyway, since I did this, and I don’t know that it was involved and, if so, how/why, I now see an ‘AirPlay’ choice in the Audacity output menu! AND, it works!

Thanks for trying to assist…don’t know why it’s now working whereas it didn’t before…I was on with AppleCare yesterday on this issue and they concluded it was probably an Airport Extreme issue but, now, who knows?!

Thanks again…David