Can't turn off playback

Audacity 2.0.3
Windows 7 Ultimate 64bit

Hello, this is my first post and i’m not even sure if this is the right forum section so correct me if i’m wrong.
I have a Shure SM58 microphone (wireless) and a imultimix 8 USB mixer and they seem to work fine.
But when i try to record anything, say i put the beat (instrumental) into audacity, and i record my voice while playing it, it seems the music is recorded too.
Also when i’m recording just my voice, it also records all background sounds and system sounds.
This doesn’t happen when i record with a regular PC mic.
So i guess it’s somekind of playback from the mic/mixer ?
Can anyone help :confused: i’ve searched in ALL the options, and i’m at a really dead end.
A friend said it’s because my microphone is wireless and that’s why there are no playback options for it on the sound tools.

You’re recording the wrong thing. Audacity > Edit > Preferences > Devices > Recording > Device. You should be recording your USB device, not Stereo-Mix, Internal Microphone, or anything else. “USB Sound Device” or something like that? It may not say the name of your mixer.

Also, Audacity > Edit > Preferences > Recording Select [X] Overdubbing and deselect [_] Playthrough.


I am recording with the microphone driver of the Shure SM58, sterio-mix is off in volume options. i disabled it in total.

What is your playback device in Audacity Device Toolbar?

If it’s the mixer then you must have the mixer set up to send what you are hearing back to Audacity to be recorded.


I am using the mixer’s microphone USB driver, and the USB driver for speakers. i’ve tried using everything. there is just no playback option ANYWHERE.

Here is how i got things cabled up. maybe there is a playback on the mixer that i don’t see.

This is the bit that Koz was asking for:

So have I got this right?
The microphone connects wireless to a receiver.
The receiver plugs into the imultimix (channel 1).
The imultimix connects to the computer via USB.
Your headphones / speakers are connected ???

If so, the problem would seem to be a setting in the imultmix. The microphone and the computer playback are being mixed in the imultimix and sent back to Audacity for recording.

Yes, but i have cheaked everywhere and there is no playback options anywhere.

How are you monitoring (listening while recording)?

I’ve tried listening while recording, i’ve tried turning without listening. it’s all the same o_o

It seems to record everything. the only way to record my voice only is to either only record vocal, or put on a song, put Output Volume on the most left and then record. but then i don’t hear the music.

OK, but how is the equipment set up? What is plugged in where?

On the picture i posted earlyer.

the red and blue is plugged into the PC, front speaker out (line in). ( the blue hole in the picture )
the Phones (where the green cable in the picture is) is plugged into the speakers on my desk.

the yellow cable in Mic1 is plugged into the shure transmiter, the transmited is powered by a cable near to the yellow cable.
the USB cable is plugged into a USB port in the back.

I don’t see a red and blue cable/plugs.
Do you mean the red and white plugs? If so, then I don’t understand why you have an input on the computer plugged into an input on the imultimix - where is the signal on that cable supposed to be coming from? Or is that blue socket an output that is labelled as an input?

Probably what you need to do is to remove that lead and plug your headphones into the computer.
You shouldn’t have speakers turned on while recording with a microphone because the mic will pick up the sound from the speakers.

Yes i meant red and white plugged into the mixer.
I am a complete amature when it comes to what has to be plugged in where.

Anyway i found what the problem was. there was a button on the mixer called “mix” which was pressed down. i pressed it up and now it’s okay.

I can record only my voice but the is a loud buzzing noise, but besides that everything is ok. my computer’s sound card is a cheapy ass one so i don’t expect much.

Now i have 1 problem left. i can’t controll the volume of the music with the spin things beneath the red and white cables.

I could in the beggining but then i changed a lot of cables and couldn’t get it to how it was originaly.

You will probably be able to adjust the computer playback level using the “output slider” in the Mixer Toolbar. Alternatively, look for a speaker icon near the time/date (bottom right corner of the Desktop).

I am unable to hear sound when using my original driver for my speakers. i could use it before. now i can only use the drivers that the USB cable gave me.

If you mean your built-in sound device, are you sure you have correct sound device drivers for it?


The drivers for it worked fine before, no reason they would not work now.
i messed up something with the cables, got no idea where to plug anything.

It was your suggestion of a driver problem. Windows Update can change the drivers of built-in audio devices. Please see the link I gave if you want to check.