Can't switch to "line in" audio input

I know this is a common issue on Mac, but none of the old forum posts I dug up were able to solve my issue.

I just bought a microphone I’ve connected to the input 1/8 jack in the back of my iMac. It shows up under my Mac’s General Settings and seems to work fine:

But no matter what I do, “line in” isn’t a choice in Audacity:

I’ve tried playing with Audio MIDI Setup but there doesn’t seem to be anything here that will help me:

What do I do?? Thanks!

Does that mic connect through a pre-amplifier or have phantom power? Most Mac’s do not have a microphone input that supplies necessary amplification to mics using a 1/8 inch (3.5 mm) connector.

To choose the Line-in, you just select the “Built-in Input” in Audacity (which is what it’s called in Audio MIDI Setup but confusingly, not in Sound Preferences).

If you don’t get a loud enough recording, it’s due to the problem above (you need a mic input).