Can't stop monitoring while recording

I am running Audacity 2.0.1 on my Mac (10.6.8). Before I start recording I click “Start Monitoring” to check that the the levels seem correct and then click “Stop Monitoring” and click Record.
However, once I do this, the sound is played from the headphones as though monitoring is enabled, but the option still shows as “Start Monitoring” and clicking on it does nothing.
The only way I can find to stop this is to go into the preferences before I click Record and disable “Software Playthrough”, but I then need to turn it back on for the next recording so that “Start Monitoring” will work again.
Am I doing something wrong, or is there no way to disable monitoring while recording? I sometimes like to do this so I can leave something recording in the background while I am doing other things (I am using a USB cassette deck to transfer old recordings to my Mac).

They’re slightly different. Start Monitoring (or click once inside the red recording meters) turns the meters on so you can check levels, but it doesn’t affect the sound routing. Playthrough affects sound routing but doesn’t affect monitoring. Run them both to get the meters and the speakers.

I generally leave both running because I have speaker volume on my keyboard, so it’s a simple matter to leave the speakers running at very low volume while I’m recording. On Live Performance, of course, it’s headphones.

I have multiple computers. Live recording while you’re doing something else is dangerous. Our entire company tries to do that and we’re constantly digging people out of trouble.