Can't save in any format at all

I am using Audacity 2.0.5 on Mac OSX 10.6.8. I’ve used Audacity for recording on this machine for several years. Now, today, all of a sudden I can’t save in ANY format at all. Not .aup, not .wav, not .mp3. Not ANYTHING. I usually save as a WAV file, but when I go to export as a WAV, the “Save” button is grayed out. Same story no matter what format I’m trying to save it in. Memory isn’t the problem, I’ve got 50 GB free on my hard drive. Length of the recording isn’t the problem either. It does this whether the file is 20 seconds or two hours long. And it just started happening today. Is there something I should know?

Export will fail if you are in Pause instead of Stop.


That’s not the problem. I know it’s stopped, not paused. I’ve even tried restarting my computer. Generating nothing but silence and white noise that requires no actual recording. Nothing works.

What’s the exact filename you’re trying to save?
Does it work any better if you Save or Export to the desktop?

Memory isn’t the problem, I’ve got 50 GB free on my hard drive.

That’s not your memory. That’s your hard drive. Apple (upper left) > About This Mac > Read Memory.

And it just started happening today.

What systems or programs do you have in Auto Update? What did you change that couldn’t possibly have anything to do with this? Did you change your Skype configuration? Change your password? Adobe Flash auto update?

There are three system tools you can try.

Go > Utilities > Disk Utilities.
Select your system drive. Verify Disk & Repair Permissions.
Close when it’s done, assuming it passes.

Go > Utilities > Terminal. Type the blue bits:

Last login: Mon Jul 6 21:19:37 on console
johnny:~ koz$ sudo periodic daily weekly monthly
johnny:~ koz$

If it still doesn’t work, I’m out.


I tried the permissions fix, and it seemed to work. Correction: it DID work. I can save things again! Thanks for the advice.

In that case, I hope your backup is up-to-date.

Changing permissions without user intervention on that level means either a slowly failing harddisk or a seriously corrupt system. The first one is more popular, I’m afraid. The second one indicates some seriously out-of-date software, or maybe even malware.

Of course, if you have been trying Terminal commands from the web without any idea what they might do, that could be a reason too.

In “El Capitan”, Apple’s next OSX version, repairing permissions is gone from Disk Utility. There’s no need to run it because every software update will check permissions for you. And in the rare case it is needed, you need to reboot from the recovery partition to make it work.

Have they removed the diskutil Terminal commands, which would be the other method to repair permissions and verify the disk?


When used under normal OSX “El Capitan”, diskutil no longer knows the appropriate command to restore permissions. All the others are still there afaik. And the gui Disk utility has had a redesign (finally, after almost 15 years!). It seems to hide more but most tools will be there by release time. It doesn’t do RAID or resizing partitions in the beta. Disk repair seems fully functional.

To repair permissions in EC, you need to boot to the recovery partition and then there is a new “security” pane in the installer, that allows things like resetting passwords and rebuilding permissions.

IMHO this is a good thing, because rebuilding permissions has become a bit of a “fix-it-all”, while in reality it’s only needed in cases like this, where the system’s permissions have become corrupt and influence user data’s permissions.

In general, EC is faster and stable. Most audio stuff works. And most software seems to work without updates. Notable exception: ProTools 11 and 12…

And some Intel HD GPU’s can use more shared memory for greater GPU performance, especially with Metal.