Can't record using laptop PC microphone

I have a brand new laptop (HP Probook). I’ve installed Audacity 3.3.3, and I cannot record using the laptop microphone. I believe I have followed all the setup steps, but by this time I’ve tried so many things that I’ve lost track.
I’ve used an older (2.?) version of Audacity for a few years, on an older Dell laptop, now out of commission, so I can’t go check settings there.
I can play back old projects. I can record from computer audio using Stereo Mix.
The microphone will record on Vocaroo (web-based simple recorder).
I’ve deleted & reinstalled Audacity. At first, when trying to record, I saw only a flat line in the waveform, and heard nothing on playback.
I then tried changing Host from MME to Windows WASAPI. This seemed to “wake it up” a bit - I saw a little activity in the waveform, but on playback I got only intermittent, muffled sounds. Recording level is set at 100%. Oddly, when switching back to MME, the behavior was then about the same as in WASAPI. Windows DirectSound doesn’t work at all.
Looking for ideas. At first I thought I had a defective laptop, though diagnostics show no problem. But, since I can record in Vocaroo, I now doubt that.

You have to select the internal mic as the recording device …

You also may have to give Audacity permission to use your internal mic in Windows privacy settings … Error opening sound device - Audacity Manual

Worth checking that “sound activated recording” in Audacity is OFF
Transport Menu: Transport Options - Audacity Manual

Thank you. Checked all 3 items; they are properly set, but the problem persists.

Turning any* “Audio enhancements” off is the only other measure I can think of … Turn off or Disable Audio Enhancements in Windows 10 - YouTube
[ e.g. a “Noise gate” recording-enhancement set high could silence input unless the signal was loud ].

[ * there can be Windows “Audio enhancements” in playback & recording, and there can be second layer of audio enhancements, sometimes called MaxxAudio ].

Wow! That worked! The mic will now record. I am still having some setup problems with plugging in a headset, for overdubbing, but I guess that’s actually another issue. But thanks so much for the idea on Audio Enhancements. I turned it off on the Recording tab only (so far).

This topic was automatically closed after 30 days. New replies are no longer allowed.