Can't record second track with overdub switched on

Hi at all!
I’m new here and i need help, because i just can’t figure this out.

OS: Windows 10, Version 1909
Audacity 2.4.2
USB Audio Interface: Mackie Onyx Blackjack

I have overdub activated:
and i selected the audio-interface as input and output:
I have tried all three of them. None Works
I don’t know if this is relevant, but i use “Mackie USB Audio Driver Control Panel” because without it, the pitch is wrong.
The Problem is:
When overdub is activated it wont record a second track. when i press record it just stops and does nothing.
Without overdub it works just fine.
Do you know what the problem is? Is it because of my audio-interface? or my soundcard? or what is ist?

I would be glad for some help!


The problem is probably because the Mackie is using ASIO and the Windows release version of Audacity only supports MME, Direct Sound and WASAPI (and not ASIO).
When ASIO is running, by default it will grab exclusive access to the audio interface.

Thank you for your answer. Do you know if there is a solution for this?

First, check if the Mackie Onyx Blackjack is listed and enabled in the Windows Sound control panel for both recording and playback.

Then check which apps start up automatically on boot - disable any that use ASIO from auto-start.

Then reboot your computer and check (again) that the Mackie Onyx Blackjack is enabled for both recording and playback in the Windows Sound control panel.

Then launch Audacity and in the Device Toolbar set “host” to MME and select the Mackie Onyx Blackjack as the recording and playback device.

Hi again. Nothing in my autostart sais “ASIO” but i tried deactivating these things in different combinations
but the problem persisted.

I also read about disabling the usb interface as standard playback and recording device and tried that:
but that didn’t work either.

I guess ASIO and Audacity just don’t work together. I read about compiling audacity on your own with visual studio, maybe i’ll try that, even i’m not an expert in things like that.
Maybe I also have to change the recording software or the interface.

Thanks for your help so far!