Can't Record Properly with Any Available Recording Option

Windows 10 Pro Operating System. Audacity Version 3.0.2.
Dell Optiplex 7010 USFF - Intel i7 Computer

Audacity correctly plays existing mp3 files through the display’s built-in speakers, and I can use Audacity to modify these files as needed. But, If I record what an mp3 player application is playing through the display’s built-in speakers, the recording sounds very “tinny”. Some years back, with other computers, this was not a problem. The other computers may have had separate sound cards, and this computer probably does not. Can anyone explain?

Does the display have a microphone? It’s a terrific bet you’re listening to the microphone picking up the display speakers.

There are ways to do a direct capture in software, but there are no “natural” ways. No single button push. Machines only have two natural sound pathways. Play music or internet work to the speakers or headphones. Full Stop. Record from the microphone or audio input to a sound file. Full Stop.

There is no natural path connecting the two unless you jam the microphone next to the speakers.

Macs have never been able to do this. We’ve always had to play special software games.


Thanks Koz. That’s exactly what’s happening… Audacity is recording the microphone input. I didn’t even know this Dell monitor had a microphone. Without a flashlight I can’t even see the flush touch controls along the bottom of the monitor. When I turn the mic off, Audacity doesn’t record at all, no matter which of the three recording options I select. On a previous computer in the olden days, an earlier version of Audacity recorded without me thinking about it. This small Dell Optiplex computer (which I like) must not have the audio hardware required.

My face is red. I thought I’d tried all combinations of audio options with Audacity, but apparently I’d not tried “Windows WASAPI” combined with “Echo Cancelling Speakerphone”. That setup produced an acceptable recording by Audacity of the audio played on the computer by the VLC media player. A portion of the mp3 fie exported from Audacity is attached. Hope my incomplete attempts at a solution have not confused or inconvenienced anyone.

To clarify. There are two Echo Cancelling Speakerphones indicated by my computer’s Device Manager. Their names are identical and virtually all aspects of their descriptions are identical, including the driver ID’s and other information. The Audacity Display shows that there are two of these speakerphones, but they have identical names in the displayed list, so I can’t tell which is which. When recording with one of them selected, the result it tinny. With the other selected, the result is perfect. Strange but true.

Indeed that’s strange. It sounds like a bug in the driver, but if you can successfully work around it then probably best to work with it as it is.