Cant record on new track

im using version 3.5.1
im recording my guitar on a sound card, and it works fine when theres no other tracks there, but when i have a playback track to play in the background or if i want to record more on the same track, it doesnt do anything. the button grays out for a second like it would if it were recording and goes right back to normal with no audio on the track. ive looked in this forum for similar problems and no solution helped

image
It might be this sort of thing you are trying to do. click Transport…transport options…
Hear other tracks …allow playback of other tracks when you click record
Enable audible input monitoring… lets you hear what is currently being recorded…
click to tick or untick whatever you want

Or it could be Audacity > Edit > Preferences > Recording > Options > Record on a new track (select)

Koz

Yes, OK…but I think this option always forces recording on a new track…

The earlier options from .Transport lets you start record from where and what track the curser is on…? …it records at end of track curser is on. and Manually need to add new track to start recording on a new track

when i toggled it on it wouldnt let me record at all

What is “it”

the program

Unbelievable…please explain so we know what your are doing…there are 2 screen dumps above on earlier posts … of possible settings…what have you tried and what happened…

i already tried the record on a new track setting so i know it wont help, itll just create a new track that it wont record on either, i tried toggling on the two settings under transport > transport options and when i did it wouldnt let me record at all, even when there are no other tracks in the project

The transport options should not stop you from recording just lets you hear other redcorded tracks and what is being recorded. With all the clicking are you sure your havent click sound activated recording…it wont record until it hears something. If you have been clicking various setting it may be better to click Tools Reset configuration to reset thing back to start and try again.

im on the default settings and i have changed nothing but what you told me to

You need to explain what you are doing and what is happening.
Did you do Tools…Reset Configuration…
post screen dumps of your settings…
If you dont explain it is like saying… My car is not working…it wont start…
















i have no idea whats relevant so heres all the settings

The relevent bits are Recording and Playback
I see you have selected the M-Audio interface.
Are you using this…? for recording and for playback…?? … I see you have the mono options.
Where is your Mic plugged in to… Where is your guitar plugged in to…
How is your audio going from interface going to PC…is it using USB-C port or adaptors
Do you want the PC speakers for playback or headphones on the interface.
Did you do “Reset Configuration”

I see you are not using “Audible Input Monitoring” … so You will not hear what you are recording until you play it back… So if you can hear you mic when it is recording the sound is coming from somewhere else. This is why you need to describe what you are doing…??

Your initial post says… “im recording my guitar on a sound card” … is that the sound card on the PC with guitar plugged into Audio in on PC…? … not using the M-Audio interface…?

If you are using various inputs you may need to enable windows Stereo Mixer in sound settings on PC…?
Your initial problem was about playing a background track in Audacity and then wanting to record another track with overdubbing etc

i am using the M-Audio interface (sound card) as a microphone
since it has a headphone jack, i keep my headphones plugged in there and my default output device is just the sound card
i also have a fifine t669 USB microphone as a secondary device and to record vocals
my guitar is plugged into the sound card
the sound card is connected directly via regular USB plug
I dont have speakers, only headphones
i did reset the configuration
when i toggle on “audible input monitoring” there is a noticable delay which is very distracting. the sound card itself has a switch to turn on the same feature, which has no delay (and also works even when you’re not recording)
that was never my problem though, i dont understand what that has to do with anything
i can record just fine, the problem arises when i want to record on a second track

I would normally call a sound card as a card that is actually in the PC…so maybe that caused confusion…?
To me the M-Audio is an interface device…a piece of equipment…?
So I assume you have a Mic plugged into Mic input on the M-Audio and the guitar plugged in to the other input of the M-Audio. and the output of the M-Audio is the USB-C port and this is plugged into USB on PC.
So MIC and Guitar will both together be recorded by Audacity if you select M-Audio as your recording device in Audacity. What you hear on the Headphones that are plugged into M-Audio depends on model and buttons pressed but is the direct sound for monitoring the mic and guitar as it is happening. After recording if your playback device in Audacity is M-Audio and depends on model you can play the PC recording back through the USB and hear recording on the headphones that are plugged into M-Audio.
You say you have a T669 mic ( think this is condensor mic) so it will need phantom power from the M-Audio pushbutton… As is described here this is recording 1 track and mic and guitar together.
If you already have a track recorded of a background that you want to play while recording a second vocal or guitar track you will need to click " hear other tracks playing" as I posted pictures earlier. When you open the background file in Audacity, make sure curser is at the correct position to start record of new track and click the Red record button…A new track should open and record your vocal/guitar and playback of background should start as well and you hear all together … note… plays from what playback device selected in Audacity which is normally your PC speakers or PC headphones… with USB audio it may play back to headphones in the M-Audio but you will then not be monitoring direct from the M-Audio you will be hearing the combined sound of your mixed recording.
If the new track does not open to record new 2nd recording manually open a new track first before click Red record button. You will not want to listen to the “Audible monitoring” so untick it or click it off from the transport menu