can't record multiple inputs with Helix Board 12 Firewire

I have an Helix Board 12 Firewire MK ii and I can’t record multiple inputs.
when I record on two channels (stereo) everything is OK, but if on Preferences/Audio i/o ,on the recording channels scroll down menu I select 8 channels, when I push the recording button, I get an error message like “Error while opening device. Please check the input device setting and the project sample rate”.
it seems like Audacity gets only two channels simoultaneously maximum.

thankx for your support

You need to select the correct device in “Edit->Preferences->Audio I/O”
Note that Audacity does not support ASIO drivers, so you must use WDM.

Exactly what settings other than the above depends on the drivers, so you will need to consult the Phonic manual, or contact their support, unless any other Phonic Helix user reads this topic.

I have had the same problems with the helix 12 board, which i bought to replace a motu 8 channel firewire interface. the motu worked fine, but audacity just wont recognize more than 2 channels with the phonix. any advice from phonix owners appreciated.

Actually, I’d like to find out how to get Audacity to record more than out track from a MOTU firewire interface. You said it worked fine. How do you assign different inputs on the MOTU interface to different tracks in Audacity? Thanks.

On multiple channel sound devices I don’t think you assign anything. Audacity starts with channel one and works up. And you only get 16.