Can't record internet radio station.

I have Windows 7 Home Premium v. 6.1, 64-bit with all updates; and have read numerous posts online on how to record internet music to my computer. I simply want to record the music from an internet radio station to any file format, and then save it to a desktop folder which I would copy to an external thumb drive to play back on another computer, using Windows Media Player.

I first downloaded and installed Audacity 2.0.5, plus lame_enc.dll, but did not download FFmpeg. The Control Panel / Sound / Recording tab is set with “Realtek High Definition Audio” as the enabled Default Device.

A. With an internet radio station playing on the external Bose computer speakers, I opened the small Windows Sound Recorder window, and clicked “Start Recording”. At the end, I clicked “Stop Recording” and a window came up where I named and saved the Windows Media Audio File to the desktop. I turned off the radio station, and clicked on the WMA file on the desktop. The black window with the musical note came up, and the blue bar started running across the window, but there was no sound.

B. With the radio station playing, I opened Audacity, and clicked the red RECORD button. The window indicated that it was recording, but the blue line was just straight, indicating no sound. Clicking the green triangle Play button started the arrow moving across, but again there was no sound.

Since neither program records, I am not sure which one to keep trying

Thanks to everyone!

Audacity can choose the device to record from, so you have to choose the correct device in Device Toolbar . You can’t just press Record and hope for the best.

Windows Media Player can only record from the device that is set as default recording device in Windows Sound (see ). Neither Audacity or any application will record from an input device unless it is visible and enabled in Windows “Sound”.

The default recording device should be a particular named input (such as microphone or line-in), not just the device name such as “Realtek High Definition Audio”.

Some built-in sound cards have a “Stereo Mix” or “what U hear” input for recording computer playback. However “Stereo Mix” can only record from sound playing through the built-in sound device. So you cannot use “Stereo Mix” to record from an external playback device like USB speakers or a USB headset.

If your Bose speakers are USB speakers they are a separate device from Realtek. In that case the only solution is to record in Audacity using the Windows WASAPI host as described in the Manual ( ).

  1. Open Device Toolbar .
  2. In the first (Host) box of Device Toolbar, choose “Windows WASAPI”.
  3. In the second (Output device) box in Device Toolbar, choose the Speakers or Headphones that you are using for listening.
  4. In the third (Input device) box in Device Toolbar, choose the (loopback) input for the same device you chose in step 3. For example, if you chose “Speakers” in Step 3, choose “Speakers (loopback)” in this step.
  5. In the fourth (Input Channels) box in Device Toolbar, choose mono or stereo.
  6. Start playing the audio you want to record.
  7. Press the big red Record button in Audacity.


Thanks for the reply.
I set the four Host Boxes of the Toolbar exactly as you said:

  1. “Windows WASAPI”
  2. “Speakers (6-Bose USB Audio)”
  3. "Speakers (6-Bose USB Audio) (loopback)’
  4. “2 (Stereo) Input Channels”
    I clicked the red Record button, and got this popup: “! Error while opening sound device. Please check the input device settings and the project sample rate”
    I checked the Tutorial, but can not find exactly how to do this.
    Now what ??


Yesterday, I posted a question about your reply to my original, but I may have deleted it accidentally.
It was to be reviewed before it would show up on the forum.
Did you get it?
Please advise by email at
Thank You,
Murray Dorsey

Moderator note: I removed your email address for your own protection - you should never post your email on any public forum like this one unless that is you actually want a flood of spam. Your post didn’t show up straight away as unfortunately we have had to implement moderation on this forum to prevent a torrent of spam being posted here much of it unpleasant and some of it downright dangerous.

As you see, it is not in this topic. Is your Can't record internet radio station. - #3 by mddosey a repost of the same question?


Right-click over the speaker icon by the system clock, then choose “Playback Devices”. Right-click over the 6-Bose-USB Audio then choose “Properties”. Then click the “Advanced” tab. In default format, choose a 44100 Hz option, preferably 2 channels if that is an option. Uncheck the “Exclusive Mode” boxes then apply and OK and OK.

Restart Audacity and set “Project rate” bottom left to 44100 Hz.

Play something you want to record, then record.

If that still errors, try checking the “Exclusive Mode” boxes mentioned above, then restart Audacity.

If that still errors, go to the “Recording” tab of Windows Sound (as above, but choose “Recording Devices” instead of “Playback Devices”). Right-click in empty space and choose “Show disabled devices” then right-click again and check “Show Disconnected Devices”. Do you see “stereo mix” or “what U hear”, or do you see a line-in? I don’t mean a microphone input.


The Speakers Properties / Advanced tab / Default Format shows a box, “16 bit, 48000 Hz (DVD Quality)” but it cannot be changed by the down triangle. The “Test” green arrow produces a series of dings. The Exclusive Mode has 1) “Allow applications to take exclusive control of this device”; & 2) “Give exclusive mode applications priority”. Both were checked. Un-checking the 2 above boxes does nothing. Clicking the “Restore Defaults” box at the bottom simply replaces the two check marks.
I then left the 3 Exclusive Mode boxes un-checked and clicked OK & OK. I closed Audacity with the Red X, and restarted. The Project Rate was already 44100 Hz. I played Internet music on the computer speakers, and clicked the Audacity red Record button, and then the same (! Error) message popped up.
Then, as you directed, I went to Sound / Recording and clicked until only ”Stereo Mix, Realtek High Definition Audio, Default Device” showed. Tried again to record, but the exact same (! Error) message popped up !!!
May I email you .jpg files, showing precisely what is displayed on the various boxes you refer to? I have a Snagit program that will take pictures of anything on my monitors. Sorry to be so much trouble. Thank you, Gale.

In that case, try setting 48000 Hz in Audacity project rate bottom left, whichever host you choose in Audacity’s Device Toolbar.

What do you mean by the computer speakers? If you mean the internal speakers and not Bose USB, the correct Audacity setup in Device Toolbar is Host: MME or Windows DirectSound; input device: stereo mix, and project rate 48000 Hz. Or Host: Windows WASAPI; output device: Speakers (Realtek); input device: “Speakers (Realtek) (loopback)” and project rate 48000 Hz.

Did you restart Audacity after that? Again, stereo mix will only record audio playing on the Realtek device.

Can you attach them here, then others can see them too? Please see here for how to attach files: .


Please see the two .jpg attachments titled “Audacity Project 4-14-14” and “My Computer”
I hope this explains what problems I am having trying to record.
I really appreciate your help!
My Computer.jpg
Audacity Project 4-14-14.jpg

Try setting the number of channels in the device toolbar to “2 (stereo) input channels”

Sorry, I did not mention that I had earlier tried the 2 (Stereo) Input Channels, and got the same Error message.
Anybody else have any other ideas at all?


Which sample rate have you got in the (Recording) Stereo Mix Properties dialog?

Do these Bose speakers have a headphones port, and does your computer have a blue line-in port? If so, you can record the speakers that way, choosing the Realtek line-in input, but this depends if you can stop the headphones port shutting off the sound to the main USB speakers.

Or you can try Total Recorder from . It is a free trial and also has a Windows WASAPI loopback recording choice.

I also suggest you could post the contents of Help > Audio Device Info… top right of Audacity.


I actually tried the Stereo setting first, (it didn’t work) and then I changed to the Mono setting.
Please—any other suggestions?

Steve is not on Windows, so it is not easy for him to help.

See my questions to you at Can't record internet radio station. - #13 by Gale_Andrews . What is the exact model number of these Bose speakers?

It may help if you would post Help > Audio Device Info… as requested.

On the “Playback” tab in Windows “Sound”, right-click over “Bose” and choose Properties. Click the “Advanced” tab. I understand you only have 16-bit 48000 Hz options, but do you have options for number of channels? If so try selecting 2 channels, even if you want to hear 6 channels.