Can't record in Win 10 or after update on older systems

Lenovo ThinkCentre 6072-A5U (originally purchased as a refurbished Windows 7 Pro O.S. which I upgraded to Windows 10 while it was still free - It had the original Windows Vista Business OEM sticker X-ed out)
SoundMAX Integrated Digital HD Audio
Audacity 2.1.3 (.exe installer)

I know this is not technically a new topic but I don’t see any recent posts and just had a repeat of the problem after updating to Creator. This is likely unique to older computers or possibly with unregistered sound card drivers upgraded to Win 10. After the Win 10 installation I was not getting any volume on playback from either stored or internet audio and could not get any recording or playback levels on Audacity.

I had seen forum entries which said that there were problems with the lack of Win 10 drivers for some older sound cards and that you needed to search for them or go to the manufacturers website to get the latest ones. The auto search through the device manager said that my driver was up to date. The installed Driver was a Microsoft version 10. something. When I went to the Lenovo website and searched for the driver I found one that it said worked for Win 10 as well as Vista, 7, and 8. It turned out to be a file named ADI_1986A&1988A&AD1882_COLAY_VISTA_DRIVER which was a Vista driver released 2007-12-11. I wasn’t too hopeful it would work but decided to try it anyway. Much to my surprise it seemed to work as I got sound to my speakers. However when I went back to Audacity I still could not record even after I tried reinstalling Audacity in the hope it would recognize the new driver. After experimenting and a little research I reset the Audacity settings as follows (The options for these settings with the generic version 10 driver were different):

Audio Host - Windows WASAPI
Recording Device - Speakers (SoundMAX Integrated Digital HD Audio) (loopback) - the critical part is the loopback setting which allows the speaker sound to be recorded because there is no direct recording option from the computer like “Stereo Mix” given with any of the audio host options.

Now I could see the recording levels and everything was back to normal until the major Creator Update was installed and recording no longer worked. Sure enough when I checked the device driver had been “Updated” to the generic Microsoft 10. version and I had to reinstall the older SoundMAX Vista driver as there was no Roll Back Driver option offered (though now I can roll it back to the non functional generic version).

The bottom line is that installing the old Vista driver may be the solution instead of looking for an updated Windows 10 version and that if you still can’t get recording level when using the computer as a source to switch to the Windows WASAPI audio host and the speaker loopback recording device options.

If anyone knows a way to prevent resetting of the driver during major updates that information would be very appreciated but at worst it is only a nuisance.

Windows 10 is not an upgrade. It’s a new operating system and it caused some very serious problems with older machines. It’s globally recommended that your systems and services have to say “Windows 10.” Not just “OK with Windows.”


I want to thank you for all the work you do on the forum and the genuine help you have given here to people in need.

My post was made in the hope that I could offer some people, who had a specific set of hardware and software and encountered the same problem I did, a solution that worked for me.

I understand your problems with Windows 10 and that it would be much better to run it on machines certified to run it but not all of us have that luxury. So those of us who are trying to eke out the most from our existing configuration or needed to acquire the least expensive system available to run Win 10 (which has the longest remaining life cycle) when their Vista support evaporated really don’t have that choice and so sometimes we need to find unorthodox solutions, like installing a Vista driver if it solves a problem.

Also while I understand that Win 10 did start from mostly new code it is still an evolutionary product based on the Windows OS structure and is not a different operating system like Linux or Mac OS X but that is really irrelevant as Microsoft offered it to those who had licensed copies of Windows 7 or 8 as an, in their own words, " free upgrade" at the time.

I know there are some functionality limitations but Win 10 is stable and working well on my machine and so was a great solution under the circumstances.

A further comment on Windows 10:

While I am not thrilled with the update reinstalling a newer generic driver that doesn’t work for my audio device I can understand how the developers did not foresee my situation when they were writing the software program.

On the other hand it is very impressive that Win 10 can even run a 2007 Vista driver in a stable functional environment let alone on an such an old hardware system.

The hardware I can understand. Each Central Processor comes with an impressive list of Known Mistakes. The next processor has its own list, etc. Whoever writes the operating system has to work at all and then work around the errors. By about the third level of that, you just give up.

SomeOS will not run on machines earlier than Some Date.

However, the driver compatibility doesn’t shock me. Nobody ever wrote software less complicated than what came before. So each improvement also bolts in features and complexity that makes it less likely to gracefully slide into the next improvement. That can give you relatively simple, unsophisticated software that happens to be good with an advanced OS. The software may not be able to cure cancer and land small airplanes, but it might do a simple job pretty well.


I have read the posts regarding the difficulty of using Audacity on old laptops updated to Windows 10, but my problem is that I have purchased a new laptop Lenovo Ideapad, downloaded Audacity afresh and still cannot get any response by running an input into the single, presumably 4 pole jack plug. I have acquired a converter, three pole to four, but cannot get any level of recording input. Any suggestions, anyone? John