Can't record -Host processes interfering

I have RealTek INTERNAL recording software that came as part of OE. Intermittently it does not work. I get the infamous -9999 error. To "record’ I have to “allow” microphone(don’t have one) to access. Sometimes that works but then I get Horrible Feedback. The problem is the “app” showing “Windows Host Processes IN USE”. That is the problem. Cant find anything in Task Manager that is appropriate. Sometimes a re-boot will let me record for a few days and THEN it starts again- the microphone Privacy Settings must be on to record
I wish I could just activate the Realtek internal system without getting the “microphone” settings involved OR find a way to silence the “Host Processes” that are causing the problem

That sounds important, but I don’t know what you mean.

Forgive me, I am trying to remember what OE is… :neutral_face:

You are not the only one: check out:

I know you have changed your host from MME to Windows DirectSound to Windows WASAPI before. Does changing this setting correct the problem? How about your project rate?

OE is Original Equipment. The Realtek software came installed on my HP computer

Which “app” are you referring to? That’s not an Audacity message.

I’ve searched Google for “Windows Host Processes IN USE” and there was exactly one hit - this topic. Is that the full and exact error message?

I assume that you mean “-9999 Unanticipated host error:”

I thought I posted a screen shot of the Host Processes.
Regarding “Host Processes” go to M.S. Windows Communities and search for “host processes” you will find that 241 people have the SAME question. The microphone being active IS the APP that is running because by turning off the Microphone privacy settings the host process goes away but leaves the Audacity not able to record… There are NO solutions!

I saw the DELL forum regarding this. I saw this “fix” some time ago and it worked for a while BUT then it didn’t THAT is the problem With the mike activated the Host Processes kick in and the horrible feedback occurs. REALTEK is the problem I guess but neither they nor HP offers a solution.

Is there any other compatible recording software that I can get?

Check in the Windows Sound control panel and ensure that “Listen to this device” is not enabled for any recording device.

The Listen to Speaker Must be on to record.
This is NOT an Audacity or Wavepad problem, it is Microsoft’s and/or Realtek.

Can anyone suggest as sound program that I could download to try. OR in the worst case scenario, a hardware fix such as inserting a sound card inside the computer?

OK. I’m curious and want to learn. Why do you say that ?

Do you mean “Listen to this device” ?
Listen to this device should not need to be enabled to record.

“Listen to this device” must be off for “Stereo Mix”, otherwise you not only record what is coming out of the sound card, you also play the sound that is going into the sound card and then record it and then play it and then record it and then play it … That’s called a “feedback loop” and it must be avoided.

The answer is right above in the screen print. Have you READ the entire file?
The “Listen to speaker” must be checked to record. The " Speaker" is Stereo Mix.

I am STILL HOPING for someone to suggest another software program I can use for recording audio to Audacity or Wavepad. - or a hardware fix.

Then there is something wrong with your configuration because that should not be necessary. We are trying to help you work out a solution, but we can’t see your computer.
What (precisely) happens if “Listen to this device” is not enabled?

In Audacity, the Listen Speaker must be checked to be able to record. There is NO WAY around that.
Other forums have ALSO reported that the Microphone Privacy options must be checked to enable recording. That WORKED for me sporadically but NOT in the long run as the Feedback came back until I unchecked the Listen Box in the recording tab and then there was NO recording at all.

I downloaded Soundtap from NCH and that will record with the Listen button unchecked, OR checked, and will save as WAV. HOWEVER, they may be doing something to the free version as there is a very small amount of the tone wavering, enough that you would not be happy with the sound quality. So BACK to square one!

I REPEAT that I hope that someone can suggest a recording program or as a last resort, a new piece of sound hardware to put into the PC as Realtek Stereo Mix is causing these problems

Thanks for all the suggestions but they have not solved my problem

Ok, I am very very concerned about this setting. I believe it is at the heart of the problem you are having. Just what is it that you are trying to record? Audacity cannot record both sides of a conversation. If you are trying to record a Zoom meeting - this is something that Audacity CANNOT do reliably. Zoom can create recordings for you - just ask them.

I like to record music off the internet and other sounds from the internet. I have been recording via Audacity for YEARS and YEARs without trouble, including my latest PC There have been a few hiccups over the years but generally it worked. . If you spent as much time as I have scouring the internet for clues, you would have seen MANY people are having sound and recording problems, mostly associated with Windows and with updates starting last April.

If you really want to help me, and I know you have all tried, just find a sound program to replace the Realtek and maybe that will work. Just go back and read my remark that I could record from Soundtap but the sound that it recorded was (ONLY) slightly less than desirable.

If there is an EXPERT software engineer out there, I can send the error reports that are created when I try to record on Audacity (with the 'microphone" privacy settings active. If you want to see what error reports look like, if you have Windows 10, try Searching -“event viewer”

CLEARLY Audacity recognizes there is a problem because it displays the -9999 error when the MIcrophone is NOT active and the speaker Listen IS active and NOT able to record.

So HOW ABOUT another solution???