Can't record guitar connected through USB (was working)

I’m connecting my guitar through a Fender amp to a USB connection on the PC. The input device on the PC is Stereo Mix (Realtek audio). It is enabled in the input sound control panel and diagnostics says it is working properly. I had this setup a few months back and it was working fine. I’ve been away from it for a few months and fired Audacity back up to record and it doesn’t work. When I turn on the recording monitor with the Stereo Mix (Realtek audio) selected as the input device, I get nothing from the guitar but the monitor reacts to internal computer sounds (e.g. a warning tone when.) I’ve done the startup and rescan audio steps in various sequences and nothing seem to work. Truthfully, it could be something really stupid, since I haven’t used the software for half a year. Also, when I initially set it up, somewhere there were specific instructions for enabling the input device in the control panel. I can’t find those instructions. Any help anyone could provide would be greatly appreciated. Buster T

Fender amp to a USB connection on the PC.

Most Fender amps I’ve ever met didn’t have USB connections. Yours does? And you’re sure it’s an audio connection. It doesn’t have to be.

Stereo Mix (Realtek audio).

Stereo Mix is the one you pick if you want to record everything in the whole world. Audio Devices, Windows Chimes, YouTube, Windows Media, Error Beeps, everything. So that’s not it.

Dig in the Windows Control Panels (Speaker on the lower right) > Recording and note all the sound things that are listed there. Unplug the amp and see which one goes away. That’s the Amp’s name. Plug it back in. Make sure it comes back in the control panel. If this step fails, then the amp is not showing up in Windows. Audacity gets its sound from Windows, not the amp.

If it’s OK up until now, start or restart Audacity. Click on the microphone window and select the same thing that appeared in the windows panel. Note Audacity only automatically checks for sound devices when it starts.

You can force a check with Transport > Rescan…

Press record, play something and see what happens.


Thanks a bunch. I looked where you said and there it was, an aux input jack with Fender Mustang amp connected. It was disabled. I enabled it and voila! It works. I guess I must have done this when I initially set it up but I don’t remember doing it. Thanks again for your quick response, but I’ll probably be up all night playing around now.

Buster T