can't record audio through WASAPI on a laptop

I’m using win10 on macbook and i haven’t got any issues with playing sounds in windows, games, apps, but I can’t record it. Audacity, OBS and BandiCam on my laptop can capture sounds from my mics, but if I tried to capture sounds from any app, game or webpage I’ve had an error - failed to start audio capture or if we talking about audacity - “error opening recording device. Error code 9996 invalid device”.

Audacity can play audio tracks and record audio from my mics, but if I choose recording device WASAPI (speakers or headphones) only thing I have is error. There is same error if i tried to start monitoring recording levels (it’s working if I choose input from mic).

I tried to disable different combinations of devices (in my laptop i have builted in speakers and mic also i used headset with mic) and I tried different hosts WASAPI, MME, Win DirectSound but it doesn’t helped.

I didn’t know which soundcard apple uses in my laptop in settings it’s called AppleSound.

MacBook Pro 15 2019
Windows 10 LTSC Version 10.0.17763 Build 17763
CPU i7-9750H CPU @ 2.60GHz
BIOS Apple Inc. 1037. (iBridge: 17.16.13050.0.0,0), 17.01.2020

Looking forward to your reply
deviceinfo.txt (6.78 KB)

problem solved!
I installed VB virtual audio cable and choose it as input.