Can't Record - Also "Error opening Sound Device"

Windows7 Acer Aspire Laptop. Audacity installed from EXE file.
According to Behringer, Guitar Link UCG102 compatible with Audacity 2.0.2.
It would be great to have both these products work as advertised, but have spent hours trying to make it happen.
Behringer Guitar Link recognized by Audacity as Input and Output, can play imported MP3 music files through headphones on Behringer OK, but NOT record.
Audio host set to MME, but whether set to WindowsDirectSound makes no difference.
When Input Device set to “Line In(2 BEHRINGER USB WDM AUDIO 2.8.40”, Get message “Error while opening sound device. Please check the input device settings and the project sample rate”.
Device settings set to 44100 and 16bit.
When Input Device set to “Microsoft Sound Mapper” or 'Stereo Mix “Realtek High Definition”, the Record will work… but nothing actually records…
In Control panel, Behringer set to Playback and Record as Default.
Checkmark put in both Exclusive Mode boxes.
Tried installing ASIO-ForAll but realize that it’s not compatible with Audacity.
Been through the Audacity FAQs and still can’t find help.

This is a recently updated FAQ:

Thanks for your quick reply Steve.
I have looked over that link you gave me pretty thoroughly I think, and I still can’t make it work. I’m sure it must be a very simple setting somewhere. Others can make Audacity and the Behringer USB device work OK.
Here is a rundown of what I’ve tried according to that link you gave me. Hopefully you might pick up on something I’ve missed…

Audacity Reply to FAQ – been to this page many times?

Why do I get “Error while opening sound device”?
I never attempted to append record or tried to overdub.

Check Audacity Settings
• Project rate set to 44100 Hz and tried EVERY other rate… Also set to 16bit
• Never enabled Transport > Software Playthrough (on/off) – Even tried with it ON and OFF
• Never turned on Transport > Overdub (on/off) – Even tried with it ON and OFF
• Checked in Device Toolbar that the output and input devices ARE correctly and explicitly selected as DEFAULT.
o On Windows, don’t choose “Microsoft Sound Mapper” or “Primary Sound Driver” which point to the current Windows default device; choose the required device by name. Try selecting “Windows Direct Sound” as the “Host” instead of “MME”.
o Tried ALL these settings in turn and still no go….

Check operating system settings
• Windows: Go to the system control panel and follow the Wiki instructions for Windows 2000 or XP or Vista or 7 to ensure all available inputs are listed and enabled. Done this…
• Behringer Playback and Record enabled and set to Default. Additionally on Vista or 7, these steps are strongly recommended:

  1. In Sound, right-click over or select the recording and playback device in turn, choose “Properties”, then the “Advanced” tab
  2. Set Default Format to the same sample rate, bit-depth and number of input channels as in Audacity
  3. Put a checkmark in both Exclusive Mode boxes (this allows Audacity to directly request the sample rate from the sound device if the “Host” in Device Toolbar is set to “Windows Direct Sound” as above).
    Note: Only Playback can be set to 44100 and 16bit and has box for Exclusive Mode.

Just another note: My Behringer GUITAR LINK UCG102 is actually a Chinese Imitation of the UCG102, even though I don’t think this is why it doesn’t work. Also, I borrowed a friends M-AUDIO FastTrack USB device and it works OK with no problem whatever.

Seems like you have been pretty thorough. We need to do some detective work to narrow down the problem.

Windows includes a simple “Sound Recorder” program that records sound from the default recording input device.
If you set the UCG102 as the default recording device in the Windows Sounds Control Panel then open and run the Windows “Sound Recorder”, it will try to record from the default recording input. If this does not work, the problem is either with the recording device, the drivers for the recording device, or the set-up in the Windows Sounds Control Panel.

A “Behringer” UCG102 requires no special drivers and will work with the standard Windows drivers.
Optional ASIO drivers are available from Behringer but these do not work with the standard Audacity release.

If recording does not work with “Sound Recorder” and you are using the standard Windows drivers for the device, then this narrows down the problem to hardware (the device itself) or the Windows Sounds settings. If you can’t get this to work, then Audacity will not work because it uses the same sound system as Sound Recorder.

If you do get Sound Recorder to work - write down what the settings are. Those settings should work with Audacity so then it is just a matter of configuring Audacity to match those settings.

Thanks Steve, did all that before…
But your explanation did help narrow down the problem to the cheap junk imitation Behringer Device.
The Windows Sound Recorder works OK with the Headphone & Mike using the onboard sounds as default.
When I make the Behringer input/recorder the default I get the message,“An audio recording device cannot be found”.
So it does look like the Imitation Behringer Device is the problem…
I will have to invest in a better qaulity device.


I have the same problem and my clumsy workaround eas to take the signal from the Behringer headphone socket into the Line-In on the back of my computer.

This worked but there were significant latency issues and it was quite strange to try and play along with anything, even doing a stand alone 12 bar blues with no backing was difficult.

Any tweaks I can do to make this work better either on behringer or audacity software ?

How do I determine whetehr or not I have a genuine Behringer or a cheap chinese imitation ?



Did you buy it from an authorised Behringer dealer?
Does it have the Behringer logo?
Does it have the Behringer documentation?
Does it include a warranty from Behringer?

Thanks for the response Steve

YES to all of the above - but they could all be faked - how would anybody know and be certain ? My question is better when it is written differently ie “By inspecting the hardware and associated documentation what are the telltale signs that the unit is a fake how does one determine by looking at the unit”

I have been looking at reviews of the UCG102 on Amazon and there are a number of people, like myself who are reasonably happy with the hardware and acknowledge that the hardware works well but who have had significant problems with the software sent with the unit.

General consensus is that the software is awful and that installing the ASIO4ALL driver is a good way to reduce latency.

Generally best and easiest way to hear what you are playing is to use headphones in the headphone socket of the unit.

People more knowledgeable than myself may be able to glean more from the reviews - definitely worth a look.

I looked at the customised Audacity installation notes - way too complicated for a ordinary non programmer like me.



When you do that are you able to hear both what you are recording and other tracks playing in Audacity (assuming that you have Audacity set to play through the UCG in the Device Toolbar and you have “Overdub” enabled in the Transport menu)?

I have the same problem and my clumsy workaround eas to take the signal from the Behringer headphone socket into the Line-In on the back of my computer.

More than clumsy. This is the connection layout to get rid of live headphone latency. Other configurations need not apply.

You must get the headphones from the USB device, not the computer.


Audacity as shipped won’t work with (and probably won’t see) ASIO drivers. Steve has said further up this topic that GuitarLink will only work with built-in Windows USB audio drivers. Audacity has got to see a separate WDM driver in the combined WDM/ASIO drivers on for those to work. I can’t recall anyone saying that Audacity works with any drivers on that page, even Behringer’s own “WDM/ASIO” drivers.

We did not write them, whatever they are. Are they a PDF - can you upload them somewhere such as for us to see?


So ASIO4ALL can be free, but the software that uses it must satsify license?

I am not a lawyer, but as I understand it:

Client software support for ASIO, (and ASIO4ALL) requires Steinberg’s ASIO SDK, but Steinberg’s ASIO SDK is non-distributable.

The GPL license requires that all of the required source code for GPL licensed software is freely available.

Audacity is released under the terms of GPL v2 license, which guarantees that Audacity will always be free software. It also allows Audacity to include other GPL licensed software libraries.

If Audacity is built using Steinberg’s ASIO SDK (required for ASIO support) then it would violate the terms of the GPL license if it was shipped without those parts of Steinberg’s ASIO SDK that are required, and would violate Steinberg’s license if it did include them. In brief, the licenses are incompatible.

Steinberg’s license does allow personal use of their SDK, but doe not allow it to be distributed. Downloading Steinberg’s SDK requires that you agree to their license conditions.

If you download Steinberg’s ASIO SDK and the Audacity source code, then you are allowed to build Audacity linked to the Steinberg SDK for your own use. You will not be breaching either of the licenses provided that you do not distribute the compiled binary. “Distribute” includes giving or selling it to others - personal use only.

ASIO4ALL is not an ASIO client application, and I assume that it does not require Steinberg’s ASIO SDK, but whether it does or not has no affect on Audacity because Audacity does not distribute ASIO$ALL.

See these links for more information:'t_Implement#Licensing_restrictions

These two seem to contrast.

If ASIO4ALL doesn’t require ASIO SDK, Audacity could be made to accept ASIO4ALL, yes?

No. To support ASIO4ALL, Audacity must be built with Steinberg’s ASIO SDK and so becomes non-distributable.