Can't record 4 channels with M-Audio Delta-44

Windows 7 Home Premium Service Pack 1
1 week old computer
Audacity 2.0.5 .exe installer

I can’t get M-Audio Delta-44 PCI audio thing to record 4 channels.

I read all this (and more) and tried everything:
Spent an hour searching and browsing the forum.

If I select host MME or Windows DirectSound with recording devices line 1/2, line 3/4, or multichannel
it will record, but only have the option for 1 or 2 channels under multichannel.
If I select WASAPI, I can select 4 channels, but it won’t record. When I press record, the appropriate number of tracks appear, but the recording cursor stays at 0 seconds and blinks. The Realtek audio on the motherboard will record with WASAPI.

I tried older drivers. I tried 16 and 24 bit. I tried “allow applications to take exclusive control of this device” on and off. Sound activated recording is off. Tried checking/unchecking overdub and software playthrough. Increased latency. Anywhere I can change it, sample rate is set to 44100. Reboots, XP compatibility mode, run as administrator etc.

I haven’t tried:
Putting the audio card in the second PCI slot.
Older versions of Audacity.
Compiling Audacity with ASIO support (beyond me.)

It worked on my old computer, Windows XP, older version of Audacity, but I had to use an older Delta-44 driver to get 4 channels to show up.

I tried this once myself and the only way that I could get it to record 4 channels was on XP with very old drivers. It seems that M-Audio abandoned the multi-channel driver for Windows and replaced it with two stereo drivers/ This is no good for Audacity because Audacity can only record from one “device” at a time, and stereo drivers effectively turns the Delta-44 into 2 stereo devices.

I was not able to find multi-channel drivers for the Delta-44 for Vista or later, so the only remaining option for 4 channel recording is to use a DAW that supports multiple devices. Reaper should be able to do this - i’s not free but it is inexpensive and offers a very generous (unlimited) free trial period.

WASAPI in Audacity ( currently only supports “loopback” recording so that does not help either.

In version 2.0.6, other sources will probably be enabled for WASAPI.
You can check out Audacity’s nightly builts to test it.

As Steve says, this is expected, unless you can run XP in a Virtual Machine with the older M-Audio drivers (though audio in Virtual Machines may have other issues such as heavy latency).

You could install XP on a partition, which would give better results than a virtual machine. This means that you dual boot, choosing XP or Windows 7 at boot time.

These solutions depend on whether the new machine supports Windows XP. You may need to slipstream later drivers or XP Service Pack 3 into the installation disc to make Windows XP run. Ask on the Forums for your computer manufacturer if in doubt.

Older versions of Audacity won’t help.

I would have thought compiling current Audacity with ASIO support would probably give you multi-channel support. You can get help on Compiling Audacity - Audacity Forum if you still want to try.

The WASAPI loopback recording won’t help you as Steve said. WASAPI loopback recording may not start if no playback stream is detected.

As Robert says - at your own risk - you could try the latest 2.0.6-alpha development build from . This will have WASAPI non-loopback support, and also support for the WDM-KS host. WDM-KS may also enable the Delta 44 to record multi-channel.

There is a very small risk that the WDM-KS support will crash your computer, which is why WDM-KS support is not released yet. If it does crash, it will probably be the Realtek device that causes the crash, so you could try disabling Realtek in Device Manager.

Please note however that is unlikely to be available until about 20:00 UTC today because the server hardware has required to be replaced.