can't open from FAT even with a non-FAT temp location set


Audacity 3.0.2, Windows 10 Home

I can’t open audio files with Audacity from the Windows explorer, from my FAT flash drive. I can start new projects and import them, or relocate the files to my non-FAT hard drive, but I don’t want to do this. My research indicates that this is due to the 4GB file limit and the sizes of temporary files, and that specifying a default temporary folder not on the FAT drive should cause the files to open with the usual Right-Click → Open With → Audacity command as they always did. However, having the default temporary folder on my non-FAT hard drive does not stop the error.

I had changed Edit → Preferences → Directories → Temporary files directory location, which did not fix the problem.

Is there a workaround for this?

That’s a secondary reason. The primary reason is that the FAT format does not support secure database transactions, which is a feature required by AUP3 projects. (FAT is an ancient (in computer terms) format that lacks several features found in modern disk file systems).

Yes. Move the AUP3 file to a disk that has a more modern file system, such as NTFS.

Oh. It’s actually just a FLAC, not an AUP3. Changing the temporary directory off my FAT drive wouldn’t solve the problem, then? I thought I understood the problem being that the temporary files could easily become too large, so just setting the default temporary directory to another drive would cause the file to just be read from the FAT drive but not edited there. If not, that’s disappointing, but still just an inconvenience.