Can't monitor recording

I am running 2.0.5 on Windows 7. I have been using Audacity successfully for a couple of weeks but tonight encountered the following problem.

I should mention that I was previously using 1.3.2 but updated to 2.0.5 and it has not solved the problem.

I am using Audacity to record my LPs, using an ART USB Phono Plus. All of a sudden, I am unable to hear anything coming out of the audio/headphone out of the PC, as long as the USB cable is plugged in.

I have the Sound Control Panel configured for the USB Audio Codec for both Playback and Recording.

I have Audacity configured to use MME and the USB Audio CODEC for both speakers and microphone.

I can record signal from the PhonoPlus, but can’t hear it with headphones plugged into the audio out on the laptop while recording. I do have the Software Play Through turned on.

I ALSO can no longer hear any audio if I simply call up one of my previous recordings and press play.

However, as soon as I unplug the USB cable, so that the PC reverts to the standard Realtek driver, I can then hear output when playing audio in Audacity.

I realize that this may be a driver issue more than one specific to Audacity but was hoping someone would have an idea of what was causing the problem. Things were working great up to today, and I am mystified as to what might have happened.

You won’t hear monitoring from the laptop’s headphones port while Audacity’s Device Toolbar is set to use Phono Plus USB Audio CODEC for playback. If after unplugging the USB cable, you restart Audacity or use Transport > Rescan Audio Devices to update its device list, then the only playback device Audacity will have is Realtek and then yes it will play to the laptop.

If you want to monitor in the laptop headphones, set the Audacity playback device to Realtek.

You can instead monitor in the Phono Plus 1/8-inch Headphone Monitor Output. Set the Monitor Source switch to listen to preamp only, then set the Audacity playback device to Realtek and turn software playthrough off. Alternatively, set the Audacity playback device to the Phono Plus USB CODEC then set the Monitor Source switch on Phono Plus to computer playback.

If you want to listen to sound in other applications on the laptop, you will need to disconnect the USB cable, or set Windows to use Realtek for computer playback.

If in Windows Sound you right-click over the Realtek device to set it as Windows default playback device while the Phono Plus is connected, then disconnect Phono Plus, Windows should not set Phono Plus as default playback device when you reconnect it.


Gale

OK, thanks.

I must have had the playback set to the Realtek setting before, because I was definitely monitoring through the PC. But what is strange is that I never changed any of the settings - it was simply working one day and not the next.

I prefer to monitor through the PC because then when I go to edit, I don’t have to move the headphones from the PhonoPlus to the PC.

Thanks once again for your help.