Can't load Audacity because is PowerPC

Hello, friends! I am a long-time, albeit casual user of Audacity. For the first time ever, when I tried to open Audacity, I got the following message:

You can’t open the application Audacity because PowerPC applications are no longer supported.

I was able to open Audacity for a project on Feb. 18th so it’s a recent problem. I currently have Mac 10.7.5 and believe I had it on the aforementioned Feb. 18th.

I tried to research this on the 'net, as well as the FAQ and the forum here to see if there is a workaround and haven’t found one that worked (I tried finding Audacity in Finder, R-Click open - and got the same message as above). Any suggestions? Reverting back to an older version of Mac OS will not be an option for me.

Fingers crossed. Thank-you!

Almost forgot - I have the latest version of Audacity…2.whatever (which is what I used in February, as well).

I assume you tried to run Audacity 1.2.6 (even if you also have a later 2.0.x version). 1.2.6 is a Power PC app and will not run on Lion (10.7) or Mountain Lion (10.8) which are Intel only operating systems. 1.2.6 would run on Snow Leopard (10.6) or earlier (with the help of Rosetta if it was an Intel machine) but 1.2.6 is now obsolete. 1.2.6 should now only be used for PPC machines on OS X 10.3 or earlier.

So send all your Audacity versions to Trash then use the latest Audacity 2.0.3 from which is a universal binary that works on both PPC and Intel machines. This means it works on 10.7 and 10.8 and also on 10.4, 10.5 and 10.6 (on both PPC and Intel machines).

If you need to check the version you have now, look at Audacity > About Audacity.