Can't Launch Audacity 2.1.2 on Windows 10


I’m having some trouble to run Audacity 2.1.2 on Windows 10. When I try to launch it, the Audacity logo appears in the middle of the screen, but it gets stuck there and nothing happens. I tried resetting my preferences, by deleting the audacity.cfg file. I also tried deleting the pluginsettings.cfg file, and nothing has worked. I ran a search on this forum, and found these two solutions:

But nothing has worked. I also tried to google for solutions, but the only thing I found was this video, which hasn’t working either:

Any ideas on what to do? I also tried uninstalling Audacity, deleting the audacity.cfg file and then reinstalling the software, but no success. Thanks a lot!

Sorry, I forgot to mention. I tried to run Audacity as administrator, which got it working for like three days. Then the problem returned again. :frowning:

Do you see any error message when Audacity does not appear?

If you have used Audacity before and plugins are the problem, the file to delete would be pluginregistry.cfg rather than pluginsettings.cfg.

How much gets written into audacity.cfg when you try to launch Audacity? If the audio devices don’t get written it could be that some external audio device or virtual sound card is the issue. You could try disabling any such devices you have.

You could try adding an exception for Audacity in your anti-virus or security application.

You could try running Take Ownership on the Audacity installation folder and Users<your user name>\AppData\Roaming\Audacity.


Hi Gale, thanks for the reply.

There’s no error message. Just the program gets stuck on the Audacity logo that appears before opening, and then nothing else happens.

Where can I find the pluginregistry.cfg file? It’s not in the Users<your user name>\AppData\Roaming\Audacity\ folder, nor in Audacity’s installation directory.

When I delete the audacity.cfg file and restart Audacity, the new file looks like this:

RecordingDevice=Microphone Array (Realtek High
PlaybackDevice=Speakers (Realtek High Definiti

I tried taking the ownership of the folder, and adding an exception for Audacity in Windows Defender, but so far, nothing has worked.

The pluginregistry.cfg file would be in Users<your user name>\AppData\Roaming\Audacity\ , but only if you had previously installed third-party plugins or had used the Audacity feature to add or remove items from the menus that contain effects.

So it appears not to be a problem with your audio devices.

Do you have any other security apps that use “heuristics” to monitor what an app is doing?

Do you have any “tune-up” utilities that modify how Windows behaves?

Did this machine come with Windows 10 or have you installed Windows 10 over another version of Windows? If you installed over previous Windows, you could try right-click over Audacity.exe > Properties, “Compatibility” tab and change compatibility to your previous version of Windows. I don’t think that very likely to help though.

You could experiment with msconfig.exe (Windows Start, type “msconfig” (without quotes) then hit ENTER on your keyboard). On the “Boot” tab you can set boot into Safe Mode to see if Audacity launches (though you will have no audio devices because the audio service won’t run). Or experiment with selected items only at startup, or “diagnostic startup”. The diagnostic startup is similar to Safe Mode but will try to determine which services you need for basic functionality.


How do I know that?

Yes, it came with Windows 8.1, and then I changed to windows 10. I tried to run on compatibility mode, it didn’t work either.

BINGO! :smiley: I ran it on diagnostic startup and it launched fine, but obviously the audio service wasn’t running. But then when I restarted it in normal startup it was working fine as well!!! So thank you so much for the help, Gale!!! Any ideas of what might actually be the cause of the problem? I fear that it work for while, then the problem returns, just like it happened with running as an administrator.

Look at your installed apps? Windows Start, type “apps &” (without quotes) then hit ENTER on your keyboard. You would be looking for something that you or another user knowingly installed, unless of course you have viruses on your computer.

Even though I assume you scan with Windows Defender, you can get a second opinion from Malware Bytes - sadly they seem to have recently started requiring your address for the free version, but it’s a good product.

Doesn’t make much sense, unless diagnostic startup has turned off some service for normal startup (which I don’t think it should), or some security app that is observing your computer for possibly unwanted behaviour has got temporarily confused.

If the problem returns I would run msconfig again, choose “Selective Startup” and underneath that, uncheck “Startup items”. You can see what those startup items are in Task Manager (CTRL + SHIFT + ESC) or Windows Start, type “startup” (without quotes) then ENTER.

If that does not help, look at the Services tab in msconfig, check the box to hide Microsoft services, then consider unchecking items that you think could be the cause. Then choose normal startup in msconfig.


I am having trouble installing Audacity 2.1.2. on a Windows 10 Pro machine also . The Win 10 OS is an upgrade from Win 7, that was a restore from Win 8.1 which I hated. Audacity 2.1.2 was an upgrade from a previous version that worked fine at one time but started freezing up. I have used Audacity for years and like it.

I tried several times to install 2.1.2 using the exe installer file (audacity-win-2.1.2.exe). The install goes fine using default settings until the finish. “CreateProcess failed Code 740” See attached. Each time I would uninstall Audacity and manually delete the folder. I did not find any remains in the registry, but may not know where to look. Audacity would open, but would freeze when trying to open a mp3 file or Audacity project. Would have to use Task Manager to end unresponsive program.

The last time I right-clicked on audacity-win-2.1.2.exe > properties > Compatibility and checked “run this program as an administrator” and ran the audacity-win-2.1.2.exe again. This time I did not get the Code 740 error, but the program still freezes at the same point.

The reason I upgraded to version 2.1.2 was my previous version was locking up at various times during editing and I’d have to use Task Manager to shut it down. I was hoping the latest version for Win 10 would solve my problem.

Fairly obviously, you have to run the Audacity installer as an administrator.

Also Audacity will default to opening and saving files in its installation directory. If that is Program Files or Program Files (x86) you must change the directory to your own user space when saving files, unless you are already logged in as administrator.

To try to fix the launch problem I would open File Explorer, type:


hit ENTER on your computer keyboard, then delete the “Audacity” folder that you see.

Then run the Audacity installer again as administrator.

If Audacity does not launch, attach the audacity.cfg settings file that may have been partially created in the “Audacity” folder you deleted in the step above. Please see here for how to attach files:


Gale, thanks for the reply. As I had stated in the original post, I had opted to run as the administrator without success. Never the less, I uninstalled Audacity and deleted the Audacity folder under Program Files (x86) and reinstalled Audacity 2.1.2, but it still froze up when trying to open an mp3 file. Even changing the file directory froze the program. :cry:
I followed bob.rs1’s experience and booted up in the “diagnostic/safe mode”. Audacity opened up fine and loaded an MP3 file. :smiley: I had trouble getting the computer to revert to the normal start up mode, but finally succeeded. For now, Audacity 2.1.2. is running just great. Thank you for such a wonderful audio editing program. I’ve tried other programs, but Audacity is my favorite.

Well, that didn’t last long. After just two days of success, Audacity began acting strangely. I started to write a post and document the irregularities but stopped because I was finding work arounds and thought it was just me getting used to a new version. But, this morning (3/9/16) I opened up Audacity and tried to click on a .aup file and nothing happened. I waited several minutes and shut down the program using Task Manager. I launched Audacity again and tried to open an .mp3 file and the same thing happened. Again, I had to force the program to close. At some point I might try opening Audacity in the Safe Mode again, but for now I have work to do.

Exit Audacity and follow the steps I gave at to delete the %APPDATA%\Audacity folder containing the Audacity settings.

You will probably be able to open the MP3 in Safe Mode. Are you sure some security app isn’t locking the folder containing the MP3? Has some other app got the MP3 open? What anti-virus and security apps are you using?


A couple months ago my hard drive crashed. I installed a new HD and began rebuilding my computer. I reinstalled Audacity 2.1.2 and it has been working perfectly since. I don’t know what kept it from working before, but I’m so glad to have it back. Thank you so much for my favorite audio editing program.

Probably rebuilding your computer fixed it. If the problems continued I would have suggested doing a fresh install of Windows 10, leaving nothing behind of the old Win 8.1 > Win 7 > Win 10 transitions and whatever applications were there.