Can't install version 3.0.5

Ubuntu 20.04.3 LTS

I downloaded from the snap store but the version wasn’t 3.0.5, only 3.0.2. I uninstalled and installed the app image from the official site, but still the same issue.

The AppImage doesn’t need installing. You just need to set permissions on the file to make it executable.

Note that the command

chmod +x Audacity*.AppImage

is just for guidance. The actual command should match the AppImage file. For example, if the AppImage file is called “audacity-linux-3.0.5-x86_64.AppImage” and it is on your Desktop, then you could use the command:

chmod +x ~/Desktop/audacity-linux-3.0.5-x86_64.AppImage

or, possibly easier:

  1. right click on the file
  2. select “Properties”
  3. Go to the “Permissions” tab
  4. Tick “Allow this file to run as a program”

Sorry for my poor English. I meant to say I ran the app image as an executable file and it says version 3.0.2 instead of 3.0.5, so, the same problem as when I install from snap.

Audacity 3.0.5 AppImage is available here:
Check the name of the file after downloading. It should be: audacity-linux-3.0.5-x86_64.AppImage
After you have set it to “executable”, double click on it to launch.

Probably best to uninstall the Snap version.

The appimage is named 3.0.5 and I uninstalled snap before executing the appimage.

If you still have the problem, try rebooting your computer.
The audacity-linux-3.0.5-x86_64.AppImage definitely is version 3.0.5


Ah the reboot fixed it. Thanks!

Excuse if my question is primary but… I just install version 3.0.5. like this:

1 - Download the file “audacity-linux-3.0.5-x86_64.AppImage” into the folder “/home/renato/AppImages/Audacity 3.0.5.”
2 - Open this folder using Nemo and right-clicked “Open in terminal”
3 - Run

chmod +x audacity-linux-3.0.5-x86_64.AppImage

4 - Reboot

Now when i double-click over “audacity-linux-3.0.5-x86_64.AppImage” it starts fine.
Then I right-click in a FLAC file, add that image file as another option (default remains “Audacious”) and new Audacity open the FLAC normally.

But that new Audacity warn it can’t find FFmpeg lib. It asks me for

I clicked “Download” and went to a Wiki page and downloaded “ffmpeg-snapshot.tar.bz2” to the folder where the image file is in. The I’ve “extract here” and there is another folder in Audacity 3.0.5 folder: ffmpeg. But there’s nothing like in there.

As far as I understand now I have to compile these source codes.

Can you please show me how to do that? Should I “Open in terminal” that folder and type some command?
And after that, where will be locate the file
Could I move this file (wherever it will be) to the folder “/home/renato/AppImages/Audacity 3.0.5.” and then point to Audacity screen?

Thank you!

In Ubuntu 20.04, Audacity 3.0.5 AppImage does not support the system version of FFmpeg. As far as I’m aware, the same is true for other Linux distributions.

The Audacity 3.1.0 AppImage which is due to be released in the next few days does support the system version of FFmpeg (I have only tested on Xubuntu 20.04).

Thank you, steve!

As soon as I see the announcement (just now), I’ve downloaded and try the 3.10 version. It opened fine a FFmpeg file but I note a problem: all the six channels are the same. I came in the library info menu and it shows me it is using “F(58.29.100)C(58.54.100),U(56.31.100)” FFmpeg library.
audacity 3.10.png
audacity 2.3.3.png
I’ve opened the same file in the 2.3.3. version and it seem to be alright.

I would like to try version 3.10 to automate some tasks, as it is in this topic here:

Maybe I’m not doing the right way or there’s some new setting… Could you help, please?

Thank you.

That’s the version in the Ubuntu 20.04 repository.

There’s some information about macros here:

and this is the list of available commands:

Well… lots of things to study.
Thank you and… here we go!