Can't install Audacity 3.5.1 on my Macbook Pro

I drag the file into my applications folder, as instructed, and nothing happens.

What do you mean by “nothing happens”?

Is the file not copied to your applications folder? Did you look there? If it is there - did you double-click it? Was there an error message telling you that another file with the same name is there? Was there an error message telling you that this other file could not be overwritten because it is open? Do you have the necessary rights (= are you an admin user) to install software?

Also not unimportant:
What exact model is your MacBook Pro, what processor does it have? Did you use the right version of Audacity (for Intel or for Apple processor)?
What version of the mac operating system is running on your device?

I dragged it to my Applications folder. It then became named Audacity Alias. I double clicked that. Nothing happened. No error messages. I’ve installed previous updates with no problem. It’s a Macbook Pro 2019 1.4 GHz Quad-Core Intel Core i5, OS Sonoma 14.4.1. 45.8 GB available of 250.69 GB. I’ve tried doing it several times. Thanks!

Figured out what I was doing wrong. Thanks! I was actually dragging the thing from my desktop into the Applications folder, instead of doing it in the image!

I am also running a macOS Sonoma 14.4.1. When I drag the 3.5.1 update file (within the box) to the applications folder, it asks if I want to replace it with the newer one you’re copying. I say yes, hopefully that’s correct and then I get this message… Can’t be completed because the item “Audacity” is in use. I’m not sure what I’m doing wrong. Brand new with Audacity and also a MacBook.

Even though you may have closed the Audacity window, the app is still running. The easiest way to close it completely is to reopen Audacity, then press Command-Q to quit the app. Then the new install should run ok. I know because this happened to me just this morning when I went to update!

Thank you so much that worked! I appreciate you responding to me!

You’re welcome. Glad I was able to help. :slightly_smiling_face: