Can't import multi-track mp4 or mkv audio [SOLVED]

Using Windows 10, Audacity 2.4.2, and ffmpeg 2.2.2. I can’t import multi-track audio from mp4 or mkv from OBS Studio 25.0.8 , but it does import single track audio. I haven’t seen anything specific in the forum about this. As a test, I created a short mp4 file where my voice is on tracks 1 and 3, and an ITunes song is playing on tracks 1 and 2. I was going to attach it, but it says it is too large.

OK, so I didn’t notice that I forgot to stop OBS recording, hence the large file size! So, I am attaching an mp4 and mkv file. So, I found that I can open either of these from the menu, but Audacity only shows 1 track. And if I try to import or drag, I get an error as if ffmpeg is not installed. I just tried to attach both files, no luck, the forum does not allow mkv attachments and it says the mp4 file is too large, it is only 2.7 mb. I’m not having a good day!

I don’t use OBS Studio.
Can OBS Studio export each channel as a separate file?

I haven’t seen that capability, I’m attaching a screenshot of the advanced audio properties.

Try making a very short file (just a few seconds) with the same format and post it here. I think you should be able to post a file that is less than 2 MB.

OK, here is a really short mp4 file

That file has two audio channels. It imports correctly for me in Audacity 2.4.2 on Linux.

You can see the number of channels by analyzing the file here:

I got import multi-track mp4 audio i’ll write about it in my [Advert removed] blog.

Thanks for all the communicatios guys, I do appreciate it. I did more research and I found a YouTube tutorial on setting up OBS Studio to record separate audio tracks. I had the main Output settings set to default “Simple”, when I changed it to “Advanced”, the audio showed that it was only saving the 3 tracks into a single track (don’t know what that means exactly). So, I just need to set the advanced output to match the tracks that I have set up in for the audio device properties (in my test there are 3), and I will make another recording and see if Power Director actually shows 3 tracks. I will get back with the results! and a Power Director screen shot.
Here is the Youtube tutorial link:

IN my previous email I said I would test in Power Director, sorry, I meant Audacity( hey, I’m retired and 70, that’s my excuse for everything now!)! anyway, I was successful with both mp4 and mkv video files! When I opened either, I was prompted with a message showing all three tracks that I had recorded! So, I selected all three and the 3 tracks opened and played fine. Thanks for the help, this post can be closed! Here is an attachment showing audacity: