Can't import mp4 files avcodec decoder failed[SOLVED]


I’m running version 2.0.3

I’m trying to import an mp4 file so that I can extract the music from it (first time I’ve tried it). When I try to drag it in, I get an Error Importing message that says it is an Advanced Audio Coding file and that Audacity cannot open this type of file and to convert it to WAV or AIFF.

I’ve tried it with a few other mp4s with no joy.

I’ve installed the FFmpeg library. The version it says in my preferences is F(52.64.2),C(52.72.2),U(50.15.1).

Can anyone suggest anything else please?

Thanks in advance :slight_smile:

Can you import this file? (It’s just a 10 second beep)

No, I can’t. Same error message.

Where did you get FFMpeg from and how did you install it?
Also, please check the Audacity version number in “Help > About Audacity”.

If this is still a problem could you do a couple of things.

  1. download MediaInfo (get the version without installer) from then open the video file in that. Click View > Text then you can copy and paste here what it says.

  2. Copy and paste the log from Audacity at Help > Show Log… after failing to import the video.


I followed the instructions on here.

Done it twice now, the first time I went to the download page linked and the second time I went to the alternative zip download link.

Audacity version 2.0.3

I was writing before the latest information.

Don’t worry about MediaInfo for now but please post the Audacity log.


Here’s the log:

14:49:59: File name is c:usershelenmusicmusicpossible sleep cd musictestbeep.m4a
14:49:59: Mime type is *
14:49:59: Opening with libav
14:49:59: Error: FFmpeg : avcodec_find_decoder() failed. Index[00], Codec[15002 - ]
14:49:59: Opening with libsndfile
14:49:59: Opening with liboggvorbis
14:49:59: Opening with libflac
14:49:59: Opening with lof
14:49:59: Error: Importer::Import: Opening failed.

I think FFmpeg could be conflicting with another version of its constituent libraries somewhere else on your computer.

Do you have any other programs that use FFmpeg? Where exactly do you have the FFmpeg you are pointing Audacity to installed?

Can you restart Audacity and post a new log from that?

You could always try putting the video file in the folder where you have ffmpeg.exe installed, open a command prompt at that folder then type:

ffmpeg -i video.mp4 audio.wav

changing the name of the video file to the name of the actual file. Call the WAV file what you like. Then Audacity will import the WAV.

I have to go now but hopefully someone else can look at your log.


Found a copy of a CD burning program that seemed to be using ffmpeg that I didn’t use. Removed that and all is working today. Phew!

Thanks so much for your help. :smiley:

I can get back to hypnosis now! Yay!

Thanks for replying that the problem was solved. I’ve marked it [SOLVED] and locked the topic.