can't import mp3 files from my computer to Audacity

I have windows 7, 64 and audacity 2.05. I downloaded it quite a while ago, so don’t know if I did the exe or zipped version.

I’ve recording some hypnosis tapes before while playing the music in the background. This time I decided to do the music on another track and combine the music and voice recordings.
When I attempted with various mp3 files to import them to audacity, I kept getting the message “no such interface supported.” One of the help topics suggested downloading Lame (which I had previously downloaded); I downloaded and installed it again. It also suggested downloading an app for some other kind of library where additional forms of files could be uploaded. I did this, with no results. I tried uploading the music as a new audacity file and uploading it with the newly recorded voice file as well. I got the same error messages either way.

I bought some royalty free mp3 recordings and would really like to add them to my recordings. I would appreciate your help. Thanks, Jean

There is no such message in the source code of official Audacity, so assuming you have Audacity 2.0.5 (there is no “2.05” version) I think this is a Windows issue.

How exactly are you importing the files - dragging them from Explorer, using File > Open… or File > Import… or something else?

Is this the error you see?

If that is the problem, I would suggest running a deep virus scan, scheduled to run before Windows boots.

If the problem persists, I would tend to backup your data and do a repair install of Windows. This normally lets you keep your files and settings. There is an alternative recommendation online that suggests re-registering all Windows DLL files but I am not sure I would do that.


Thanks for your response! The error message I got did not come from explorer so I opened Audacity to try again and check the error message. I got a different but similar response. In this case I noticed I had misspelled the file. I searched again with the correct file name and this time it uploaded the one it wouldn’t upload earlier. For good measure I was able to upload a second mp3 file. Previous to “giving up” and asking for help, I had restarted the computer after I had downloaded Lame. I’m pretty sure I tried again unsuccessfully to upload. Then I worked on other stuff for an hour. Perhaps the computer Gods were smiling on me. I’m so glad it wasn’t as serious as it sounded! Thank you for your time and information–I was expecting to have to wait for a day or so. Again, thanks, Jean

Thanks. We can’t really explain or help further, but “misspelling” a file name does not matter unless you changed the “extension” after the last dot in the file name. You should avoid that - if you know it is an MP3, don’t change the extension.

Rebooting the computer can often help weird problems.