Can't hear playback on Audacity 2.0.1 on Win 7

Dear Anyone.

OK, this’ll take some expert about 2 seconds to answer but it’s sure got me beat. I’ve got Windows 7 on a Foxconn 2ADA 1.00 Motherboard. The sound I THINK is coming directly off the board, I wish I was a tech-head with computers but I can’t see a soundcard in there, the speakers are in a little jack adaptor that converts their smooth-end jacks to one with a little ridge in it, which I know is necessary to make stereo (though don’t ask me to describe why, I’m only the synth player here!)

I’ve got IDT High Definition Codec as the input, Speakers/Headphones (IDT High Definition Codec) as the output. When I record, I get a nice fat waveform. That seems to be fine. When I press playback, all the little green lines are flashing - I just can’t HEAR anything! Yet I know those settings CAN work because I downloaded NCH Tap Recorder (note: do NOT ever have NCH Tap and Audacity running simultaneously, you will get a blue screen of death!) and recorded using that without changing any settings anywhere. That played back fine. Imported the file into Audacity, all the lights flashed, no sound. It’s the latest version, 2.0.1.

How do I get sound out of it? And why do the settings that work for NCH Tap NOT work for Audacity (or are they working? I’m getting flashing lines of light and wave forms don’t forget. And if I export the waveform as a .WAV/MP3, everything else plays it fine. It’s just Audacity that’s silent.)

And it’s Audacity I use to make/check recordings all the time, cos it’s BETTER than the NCH ones - when it works!

I promise I’ll try anything anyone tells me and report back if asked to.

Yours hopefully

Chris.

Audacity playback can be set independently of the system or other programs using the Device Toolbar.

http://manual.audacityteam.org/o/man/device_toolbar.html

Koz

Audacity 2.0.1 is not the latest version, it is several years old. I suggest you uninstall it, run an overnight deep virus check, then when your computer is clean, install Audacity 2.1.0 from http://audacityteam.org/download/windows.

As Koz said, check you have “IDT High Definition Codec as the input, Speakers/Headphones (IDT High Definition Codec) as the output” in Audacity’s Device Toolbar.

When you have selected the correct playback device, turn the Audacity output slider up in Mixer Toolbar, by the speaker symbol:

Make sure you did not turn the gain down -…+ to left of the blue waves.

Play your song in Audacity, click the speaker icon by the system clock (that is, not in Audacity), then click “Mixer”. In the window that opens, make sure you have not muted the Audacity output slider.

If none of that helps, reboot the computer.

That’s another indication your driver system is broken and/or you have viruses.

After the virus scan, look in the memory dump for the causes of the crash. See http://manual.audacityteam.org/o/man/faq_errors.html#reboot for how to do that. The dump could indicate a hardware issue, or video driver or audio driver issue.

Whatever the dump indicates, if you installed the motherboard yourself, go to the Foxconn web site and install their latest audio drivers for Windows 7. If you have 64-bit Windows 7, be sure to install the 64-bit audio drivers.

If you did not install the motherboard yourself, go to the computer manufacturer’s site and install the correct 32-bit or 64-bit audio drivers for your computer model.


Gale

Dear Everyone.

Did the virus check, got rid of 41 P.U.P’s, didn’t make any difference. Then I discovered Permissions in Windows 7 (XP doesn’t do this Permissions thing) - I clicked the ‘let a program take control of the speakers’ buttons and for one glorious moment Audacity was actually playing back sounds (the latest version of Audacity!)

Then it stopped again. Back to Square One. It’s recording a nice fat soundfile, you can see the wiggles. What it WASN’T doing was recording the effects, everything was being recorded bone dry even if I could hear the effects in the music software. The software’s Quick Score Elite Level 2. I’d never had this problem in XP, it’s only just started happening in 7. I managed 2 takes, both of which came out audible but with no effects on. Then it stopped playing back again. The green lights are flashing up and down the playback bar, just no sound.

Could that be because it and QSE are fighting over the same outputs? This is a pure guess, but if both programs need permissions to use the output channels (I know Windows doesn’t have many outputs but I’m vague on this) and QSE’s winning the ‘fight’, would that be why Audacity can’t play back? I’ve only got 2 choices for output, one is the Stereo Speakers, the other is the Headset. Of course I’m choosing Stereo Speakers but even if I choose Headset, no playback. And I don’t get why both working takes had the sounds but not the effects. (They won’t play back in Audacity any more either!)

Thing is, NCH Tap can do it, but it’s too simple a program, you can’t do anything with it afterwards. So it IS possible to do it. I just don’t know what NCH Tap is doing that Audacity isn’t!

Yours frustratedly

Chris.

Do you mean the “Advanced” tab of the Speakers Properties in Windows Sound “Allow applications to take exclusive control of this device”? That is a bad choice to enable because it could allow any other application you are using to take exclusive control. I suggest unchecking that box.

What host are you choosing in Audacity’s Device Toolbar? If you are not choosing MME Host already (the first box), try MME.

Does Quick Score Elite apply effects or is some other app applying effects? Are these MIDI effects? Audacity does not record MIDI.

I would expect Audacity to error rather than play silently if that was the case. Also see above.

Also did you follow my advice and ensure you have updated audio drivers? Erratic behaviour is a common symptom of inappropriate audio drivers. If you updated the same computer from XP to Windows 7 you absolutely must get updated drivers that are meant for Windows 7.

Until you get to the bottom of it, why not record the works with effects in NCH Tap, save the recordings in Tap as WAV, then import the WAV into Audacity?

Gale

Dear Gale.

Because, if I do that, I’ll be able to hear the sound in NCH Tap but not in Audacity. I’ll be able to see all the lights moving in Audacity but I won’t hear any sound coming out. Tried it with .WAVs and .MP3s. Audacity flat don’t seem to want to play sounds in Windows 7.

I’m getting nice fat waveforms in Audacity, don 't f orget, it’s just the playback’s not coming outta the speakers afterwards. I’m beginning to wonder if it’s one of these bugs that’ll be fixed ‘in a future release!’ Windows 7 IS a fairly new thing and perhaps it takes open source software a while to catch up. I say this because, and I do not think there’s any connection bar Open Office being Open Source too, Open Office won’t print different fonts. Can see 'em, only ever get times new roman printing out, they all worked iine in XP. Maybe it takes open source software awhile to catch up. I dunno.

Going to go back to bashing my head against this one. As most other pieces of software can play back sounds - including VLC - there’s gotta be a way for Audacity to do it too. It did it twice before failing again without the settings being changed so it IS possible. Sorta - rememberiong those two times didn’t have any of the effects from QSE on, they were just very raw versions of the basic sounds I was using.

Yours respectfully - if a little frustratedly -

Chris.

You said you were not recording the effects in Audacity, therefore the advantage of recording in Tap would appear to be that you could record the effects. Or does that not record the effects either? As I asked, what app is producing the effects?

Also before, you appeared to be suggesting that Audacity only had the problem producing audible output when Quick Score Elite was running. Now you seem to be saying Audacity produces no sound even when Quick Score Elite is quit - is that so?

Audacity has had a rare intermittent problem on Windows for years that every now and again, it appears to produce no sound. Any one machine may never experience it, or may do so once in five years. The best answer is to reboot. Have you done that?

Have you tried MME host in Device Toolbar?

Have you made sure Audacity isn’t muted in Volume Mixer?

Have you been to the appropriate web site to install or reinstall the correct 32-bit or 64-bit audio drivers for your computer?

Have you examined the memory dump to see why you’re getting crashes?

I am only saying what I would do in your situation. It’s pointless you posting here about “bashing your head” if you are not prepared to try the numerous suggestions I’ve made. If you have tried them all then please say so, so we know. You did say

Gale

That’s just it - I have tried it all, even thought about reinstalling Windows 7 but still can’t hear anything coming out of Audacity. Apart from those two times when I was getting really strange output. It wasn’t distorted, that gives the wrong impression, it was just far louder than the volume QSE was using and sounded raw and garish. A if someone was bashing the piano too close to the microphone, is the best way I can think of tho describe it, and I don’t even play a keyboard, I put everything in with the mouse.

I have tried everything everyone’s said, Sorry if I gave the impression I hadn’t. I’m just getting more and mor e puzzled.

Yours head-screatchingly

Chris.

Well, KINDA success, I’m attaching a small recording so you can hear the prob.

I used the MME setting along with Headphones/Speakers setting from my motherboard (it’s not a soundcard cos when I bought this motherboard I didn’t realise PCI and PCI Express weren’t the same thing and my lovely Soundblaster Motherboard AND my M Audio Audiophile 249g don’t fit so I’m working off the motherboard swound-chip? Section? Bus line? Whatever it is.

Anyway, this is a snippet of Richard Clayderman that sounded perfect on Windows Media Player AND VLC. As you’ll hear, it now sounds like it was on a tape recorder and te tape got twisted in the mech., can thnink of no other way of describing it. And if I record my own stuff from QSE, it sounds exactly the same. Like everything’;s twisted.

I do try out everything, honest! And I hope you can hear it, Audacity played it back once, sounding twisted, then refused to play it back any more. Never had this problem in XP, not once. Things WORKED in XP!

Yours respectfully

Heres the snippet.

You have said you want to record effects with the audio but unfortunately have not answered about how the effects are applied.

If you don’t like the phaser effects in your snippet, try turning off all sound card effects and turn off all recording enhancements Windows 7 provides that are optimised for recording VoIP conversations. Please see:
http://manual.audacityteam.org/o/man/faq_recording_troubleshooting.html#enhancements. You may have to dig in Windows Sound and in any sound control panel that the motherboard sound device provides.

The 2ADA motherboard seems to be no longer supplied by Foxconn. Where did you go to check its drivers and where did you get its drivers from originally? Do the drivers come on a CD supplied with the board? That motherboard appears to use an IDT 92HD73E audio chip and will require drivers meant for that chip on Windows 7. Is your computer 64-bit? If so the drivers must be 64-bit.

If your IDT chip comes with Beats Audio as I have seen online then you may not be able to record properly. Beats Audio often adds sound effects and distortions that can’t be controlled, from reports made here.

Apart from that, how exactly are you recording computer playback in Audacity - is your recording device in Audacity’s Device Toolbar the IDT stereo mix input? If you choose Windows WASAPI host then the speakers (loopback) recording device, what happens?

If your motherboard audio can’t be configured properly even when you have the proper drivers for it then does your computer have an empty USB port? if so you could buy a reasonable USB sound card for about $30.


Gale

Dear Gale et al.

For starters, thanks for your patience with this computer idiot here! Secondly, I’d never heard of external soundcards, I’m living in the UK, I’ll have to look into them. If they come in a caddy - I suppose they must do if they’re USB, I mean you wouldn’t have an uncovered card lying on the desk waiting for stuff to get spilled on it, would you (not that I drink THAT near my computer but you know what I mean) - I might be able to swap it out for my lovely M-Audio Audiophile 2496.

Just 2 moire questions. I tried experimenting with internal playback/record settings and ended up with a feeback loop so bad I had to use System Restore on the computer. Anyone know ROUGHLY what the R ecording/Playback settings SHOULD be on - I mean I know the wording would be different on different computers/motherboards/soundchips but a rough working combination so I know what to try without killing the system again?

And second - would it be more likely to be a Windows 7 prob/glitch, or an Audacity one, or a prob. with the Foxconn motherboard? Has anyone else here had probs. with recording/playback on Windows 7 or Foxconn motherboards? I honestly don’t know what to try next here, because I don’t want to naff things up any worse than they already are again.

Yours respectfully

Chris.

I suppose you are using a desktop?

The only time I remember that internal feedback killed an OS, was on a computer that had a weak and old power supply. We changed the PSU and the problem was gone.

It wasn’t with an M-Audio Audiophile 2496, but it had a PCI soundcard in it. Don’t remember which one, it was years ago.

A USB audio interface is much less susceptible to this kind of problem, but potentially comes with other problems, such as ground loops inducing hum.

Unfortunately, there’s no way to test the PSU without taking the desktop apart.

External USB sound cards/interface come in an enclosure, yes.

Yet another indication that the motherboard or other parts of the computer are faulty, or the motherboard is missing its proper drivers, in my opinion.

In Audacity’s Device Toolbar, MME host, IDT stereo mix for recording, and IDT Speakers or headphones for playback.

Or use Windows WASAPI host as in Steps 1 to 7 below. If you do that, you would be better to turn off Exclusive Mode for the IDT Device in Windows Sound (turn it off for both playback and recording). This is because you say you want to use unknown other applications to produce sound effects.

  1. In Audacity, open Device Toolbar.
  2. In the first (Host) box of Device Toolbar, choose “Windows WASAPI”.
  3. In the second (Recording Device) box, choose the (loopback) input for the IDT speakers or headphones you are using for playback. For example, if you are using “IDT Speakers” for listening to playback, choose “IDT Speakers (loopback)” in this step.
  4. In the third (Recording Channels) box, choose mono or stereo.
  5. In the fourth (Playback Device) box, choose the IDT Speakers or Headphones that you are using for listening.
  6. Start playing the audio you want to record.
  7. Press the big red Record button in Audacity.

In either case above, turn off Transport > Software Playthrough in the Audacity menus. If it has a tick mark, click it to remove the tick. Otherwise you will get feedback.

As I already said, lots of people have problem with Beats Audio, which may appear on the particular IDT chip that your Foxconn motherboard uses.

I am curious why you expect us to carry on answering your questions when you choose not to answer ours, making it near impossible to help you.

In a nutshell, if you have Beats Audio, buy an external USB sound card. If you don’t have proper Windows 7 drivers for the Foxconn motherboard, or if it continues to behave as erratically as you describe, buy an external USB sound card.


Gale