Can't hear beat while recording vocals

I have everything plugged in right and the settings seem fine. I can record vocals but I don’t hear the beat. I play the recording back and my vocals are there over the beat, but it’s pointless because when I’m recording the vocals I can’t hear the instrumental I’m recording over. This is important as I’m essentially only trying to use Audacity as a kind of karaoke machine. I just want to be able to record vocals while hearing the beat. I have Windows and a USB Samsung GoMic. Overdub is unchecked. I’ve followed all the advice and looked at tutorials and nothing seems to fix this problem. Any suggestions? They’d be appreciated.

Overdub should be checked if you want to hear the backing track …

That and de-select Playthrough.

You should have your headphones plugged into the GoMic and the GoMic selected as a playback and record device.

The Overdubbing setting means Audacity “knows” it needs to send you the backing track (or whatever you want to hear). If you plug your headphones into the computer, you will either get nothing or your own voice delayed. Your live voice from the GoMic should be perfect.

I can’t tell if the GoMic has a volume control. Does it?