Can't get Zoom H6 to work as audio interface.

Windows 10, Audacity version 3.2.1.

I can’t get my Zoom H6 to work as an audio interface with Audacity. It worked in the past and I recorded the Audacity preferences when it worked long ago but it doesn’t work now. I followed all the instructions I can find online with no luck. One thing I know is that the Zoom 6 settings are correct so it must be an issue with Audacity settings, drivers, etc. The H6 is practically brand new. (The screen failed on my first H6 and Zoom sent me out a brand new replacement that has only a couple hours of use on it and it works perfectly otherwise.) Attached (hopefully) are the Audacity device settings. However, I tried just about every combination of settings and I always get the same error message (also attached) that means little to me. I’ll also attach the description of what the error message.

Any suggestions would be greatly appreciated. I’m just about at my wit’'s end.
Audacity error message.jpg
Audacity error explanation..jpg
Audacity device settings..jpg

Buried in those instructions is to split Recording and Playback. Send Audacity playing back to the computer’s headphones, speakers, or other built-in sound. Right now, you don’t know exactly what failed. Test that. If everything starts working, then it’s the playback side that’s in trouble, not the record.

Audacity gets its sound from the computer, not the device. Dig into the Windows Control Panels and see if they’re rational. If your goal is to live record from the two H6 microphones, you have to set the preferences so only those two go down the USB connection. That it doesn’t try to be a multi-channel interface. Multi-channel gets magic in a hurry.

it works perfectly otherwise.

Does it connect to a different computer or different Windows software?

Desperation Method tells us to check that the H6 can record and play as a stand-alone recorder. No computer. My much smaller Zoom can even do overdubbing stand-alone if I ask it nice.

As near as you can tell, why did the original machine fail? It was replaced under warranty, right?


Missed one. Clean Shutdown the machine. Shift+Shutdown > OK > Wait. Start and Do Not let any other software start. If the symptoms are different, report that, even if it doesn’t start working correctly.


Thanks. I’ll try to check those things out tonight but, not being a PC whiz, I might not be able to find the problem. I haven’t tried it with another computer so I may install Audacity on an old laptop I have and give that a try. In fact, I’ll do that right now. I do record with the H6 alone but, for what I want to do, I want to record directly into Audacity to add tracks in real-time to existing projects. For the immediate project, I’m recording with a guitar into the Zoom. I’m not using the X/Y or any other mic. As I mentioned, I was able to do that previously but that was a few years ago with an older version of Audacity.

Again, thanks for your help. I really appreciate it.

…I don’t own a Zoom but I looked at the user manual online.

This may be something you already know but it has to be configured as an interface. I assume that the USB interface is used for file transfer by default.

And there are advantages to using a stand-alone recorder.

Of course, people do some “serious” pro recording with computers but with a computer there are lots of things that can go wrong, And you are basically fighting with the multitasking operating system because it’s always multitasking, even when you’re running only one application, and the audio can get interrupted. Buffers are used to avoid interruption of the audio, but sometimes you still get a glitch, and buffers create latency (delay) which can sometimes be a problem.

OK. I installed Audacity on my laptop. No luck. When I hit record, I got the same error message as on my desktop. Then I changed the device settings to what all the information I can find said they should be and record still doesn’t work but I get a different error message (number 1). Then, I disconnected the H6 and plugged in a little mono mike for PCs and Audacity didn’t even recognize it. I made sure the mic wasn’t disabled in Windows but still no luck. I get the same Number 1 error message which doesn’t help. So, about the only thing I accomplished is confirming that the problem has nothing to do with the H6. At this point, I really don’t know what else to do. ss :neutral_face:

I’d be a lot more comfortable with this if you could get one pathway to work beginning to end. “I was able to get my H6 to work on my computer using “________” software, but not Audacity.”

You are the poster child for having multiple problems and any one of them can prevent useful work.

There are several places you have errors like: “There is something serious wrong but we don’t know what it is.”

There is a troubleshooting technique where you keep reducing the system to a simpler and simpler form until it starts working, or proves why it doesn’t. Then work up from there. That’s why I asked you to play to the computer’s sound system and see if the H6 recording starts working.


Audio interface worked with the H6 in Audacity in the past. But that was an older version of Audacity. I had no problems at all then. In fact, I used the H6 as an audio interface many times previously with no problems, just not recently.

I did set it to play to the PCs sound system. No luck. Same error.

Audacity doesn’t even recognize the H6 now.

As I think I mentioned, the original H6’s screen failed. I learned that that was a common issue with some H6’s so I contacted Zoom. Zoom immediately replaced it with a brand new H6 even though my old one was far past warranty coverage. They even let me keep the old Zoom microphones so I have doubles. I was extremely surprised and happy with how Zoom backed up an out of warranty product.

The odd thing, Audacity won’t record with my laptop either even when I use a microphone directly into the laptop eliminating the H6 from the setup. Audacity doesn’t even recognize the microphone (with the laptop) and, no, it’s not a condenser microphone that needs phantom power. It’s just a tiny microphone that came with the PC long ago. I installed the latest version of Audacity. So, the problem seems to something with Audacity because the H6 worked as an audio interface with the laptop in the past too. The H6 has been eliminated as a source of the problem. I also tried several data USB cables that I know work because I can transfer files from and to the H6 and PC.

I’ve tried every setting I can think of with no luck. Really weird. At this point, I can’t think of anything else to try. My sound system is Soundblaster X-Fi Extreme Audio and it’s working perfectly for playback of music, etc., if that means anything which it probably doesn’t but I thought I’d mention it.

Sound settings on the PC DID show the input being the H6 but it won’t record. I just got the same error message no matter what settings I try. But now it doesn’t even recognize the H6. As for settings, I took screenshots of what worked in the past (when it worked) for future reference but those settings don’t work now.

Scratching my head…

Configuration error.jpg

Audacity doesn’t even recognize the H6 now.

So the record side is very broken.
The latest machines and versions can have security/permission issues that prevent some connections and services. And that’s about the limit of what I know about it. Do you know where the Windows security control panels are?

Roaming is magic. That’s the setup which allows two different Audacity’s, one normal and one roaming. The regular one installs normally and its personality files are available to other software and Audacity installs and upgrades.

Roaming is self-contained. If you make a change to the roaming Audacity, that’s the only program that sees it. Sometimes developers have a Roaming Audacity set to the newest version to check it for stability and life expectancy without damaging anything else.

As far as I know.

You can’t run two Audacity’s at the same time. But you can easily have two very different Audacity’s for different jobs, one after the other.

I’m not sure why you have a Roaming Audacity on your machine.

Other forum elves may be along.


I found the problem. It was a privacy setting on the PC. The mic was turned off.

I feel like an idiot but at least I’m happy because I was about to give up.

I really do appreciate your help and I apologize for any inconvenience I caused.