Can't get a signal through to Audacity for recording

Hi All, I’m new here but fairly technically savvy. I cannot seem to get my ION USB turntable to be recognized by Audacity. I’m running on an iMAC, Big Sur V 11.2.1, Audacity V 2.4.2. I have enabled the turntable input “USB PnP Audio Device” in both iMac Audio preferences and Audacity preferences. The iMac shows the input level coming through just fine is I know the signal making it to my computer but I cannot get the signal recognized by Audacity. It’s set up under Audio Devices as “USB PnP Audio Device” 44,100HZ, 2ch 16 bit integer. I tried hitting the record button and the meter show no activity and the track is blank although the recording bar moves forward but just leaves blank gray space.

I’ve tried running the turntable through my Allen and Heath usb mixer with the same results, basically no result.

I’ve included a screen shot for reference.

Thanks, Ben
Audacity - 1.jpeg

Have you given Audacity permission to use the “microphone”? (Apple uses the word “microphone” to refer to any audio input device)

Thank you Steve, that was the problem. I would not have found that one on my own for at least another week! Works like a charm!