Can't find stereo mix [SOLVED]

I’ve been using Audacity (avidly!) for… How long…
Doesn’t matter. It’s been working fine, and I’ve been gaining skills.
But tonight when I loaded Audacity (2.0…6], and tried to record… the audio input is flat-lined at zero…
…and I have failed so far to find any way to get it to hear what I’m hearing on my speakers.

I’m running Windows 7 Professional
Input selection in Audacity is (as it was) MME Speakers: Realtek High Definition Audio

I suspect this has something to do with recent upgrade of Adobe (peh…) Flash Player, Shockwave, and Quicktime.
My Mozilla Plugin Check told me I also needed to update my JRE… so I did that, and all my media plugins are now current.

When I did this, though, I lost my audio. I cursed myself for having updated everything at once without setting a Restore Point… but I needed the updates in any case…
I ended up solving the problem by uninstalling then reinstalling my audio drivers in Device Manager. After a couple of reboots everything worked… until now.

I haven’t uninstalled and reinstalled Audacity… . . mostly because I didn’t remember what (if any) custom settings I had made, and didn’t want to lose them.
I did, however, upgrade from 2.0.5 to 2.0.6. It wasn’t enough. Still no audio signal in Audacity.

Any suggestions?

Let’s start with “what works?”.
Does Windows Media Player work?

Have a read of Tutorial - Recording Computer Playback on Windows - Audacity Manual.

Device Manager does not always have the most appropriate sound card drivers. See Updating Sound Device Drivers - Audacity Wiki for how to obtain correct drivers from the computer or motherboard manufacturer.


I decided to follow a basic Audacity installation tutorial to find out what might be wrong in the setup.
The answer was fairly simple… (ergo somewhat embarrassing :blush: ), but I’ll post it here in case it helps anyone else.

When I reinstalled the Audio drivers, it did not automatically enable “Stereo Mix” for my Input options… which is what I needed.
I noticed that Audacity was picking up input from my mic, but I could not determine what to select… But that’s because “Stereo Mix” wasn’t listed an available option.
To reset this, I started the Sound (control window) from Control Panel. Then, on the Recording tab, enabled Stereo Mix, and set it as my “Default Device”, while leaving the Microphone as my “Default Communications Device”

So now everything is as it should be. Thanks for your replies.