Can't find libmp3lame.dylib file for mp3 export[SOLVED]

When trying to export audacity projects as MP3 I get this dialogue box that says;
‘Audacity needs the file libmp3lame.dylib to create mp3 files’
with a browse box saying;
‘Location of this file is User/local/lib/libmp3lame.dylib’
I’ve installed lame for Mac.
Any ideas ?

There is no User/local…

There is a /Users… and a /usr/local…

I remember there was some serious discussion of where those two (MP3 and FFMpeg) files were and where they seemed to be. I know they appear to let you put them anywhere, but that doesn’t work.


Whenever the LAME installer does not seem to let Audacity find the installed library, get the LAME zip for Mac instead and extract the libmp3lame.dylib where you want.

The best place to extract the dylib file into is the “Audacity” folder in /Applications from which you run Audacity itself.

Then Audacity > Preferences and choose “Libraries” on the left. If necessary, press “Locate…” to right of “FFmpeg Library” then in the window that appears, press “Browse…”. Select and open the dylib file that you extracted from the zip then OK all the dialogue windows.


Brilliant thanks. That worked perfectly :wink: