Can't enable high & low pass filters


Using Audacity 2.4.1 on Linux Mint 18.3 Sylvia 64-bit.

I can’t activate the High pass filter & Low pass filter.
I activate them but can’t find them anywhere after. If I remember well they should appear in the effect drop menu. If I check again in effect/add remove plugins they are disabled again though I just enabled them.


Thank you.

Exactly the same is happening to me. if I enable Low-pass filter (Dominic Mazzoni release 2.3.0) it does not stay enabled, whether I restart Audacity or not.

I am using Audacity 3.0.4-alpha-20210802 on 5.4.0-84-generic #94-Ubuntu SMP Thu Aug 26 20:27:37 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux



The High and Low Pass filters are Nyquist effects and should be enabled by default.
Are any Nyquist effects enabled? Look in the Generate menu - what is listed in there?

Look in “Edit menu > Preferences> Effects”. Are “Nyquist” effects enabled?

A rather delayed reply to Steve. Perhaps someone may pick this up if Steve doesn’t.

The High-pass and low pass filters exist in the Generate Menu (add/remove plugins), but both are disabled and if I enable them, they do not stay enabled - exactly the same as the add/remove plugins in the Tools menu. I have checked that the /usr/share/audacity/plug-ins/highpass.ny file, that is referenced, exists.

This is the /usr/share/audacity/plug-ins/highpass.ny file contents

$nyquist plug-in
$version 4
$type process
$preview linear
$name (_ "High-Pass Filter")
$manpage "High-Pass_Filter"
$debugbutton disabled
$action (_ "Performing High-Pass Filter...")
$author (_ "Dominic Mazzoni")
$release 2.3.0
$copyright (_ "Released under terms of the GNU General Public License version 2")

;; Released under terms of the GNU General Public License version 2:
;; For information about writing and modifying Nyquist plug-ins:

$control frequency (_ "Frequency (Hz)") float-text "" 1000 0 nil
$control rolloff (_ "Roll-off (dB per octave)") choice (("dB6" (_ "6 dB"))
                                                        ("dB12" (_ "12 dB"))
                                                        ("dB24" (_ "24 dB"))
                                                        ("dB36" (_ "36 dB"))
                                                        ("dB48" (_ "48 dB"))) 0

  ((< frequency 0.1) (_ "Frequency must be at least 0.1 Hz."))
  ((>= frequency (/ *sound-srate* 2.0))
      (format nil (_ "Error:~%~%Frequency (~a Hz) is too high for track sample rate.~%~%~
                   Track sample rate is ~a Hz~%~
                   Frequency must be less than ~a Hz.")
              (/ *sound-srate* 2.0)))
  (T  (funcall (nth rolloff '(hp highpass2 highpass4 highpass6 highpass8))
               *track* frequency)))

Steve suggested that I look in “Edit menu > Preferences> Effects” to see whether “Nyquist” effects are enabled, but I cannot see any reference to Nyquist, as per attached image, although everything available there is enabled.

I gave up on this in 2021, but I wanted to try it again in 2022. It seems that it is still a problem and a frustration for me.

I would be grateful for anyone to let me know how they resolved the problem, as the High and Low pass filters are fairly fundamental tools for me and perhaps other users.

It seems that your version of Audacity has been built without support for Nyquist plug-ins.
(An AppImage version of Audacity for Linux is available here: Audacity ® | Downloads)

It should look like this: