Can't configure FFmpeg

I have installed Audacity version 5.0.1 on my Windows 7 prof 64 bit PC. Works fine. I want to export to M4a. I have downloaded FFmpeg add-on - FFmpeg 0.6.2 . I now have a directory on my pc called FFmpeg_v0.6.2_for_Audacity. 1st put in the Windows program area. Using preferences → libraries it wasn’t happy. So I put it in my User area as possibly the Windows area is restricted access. I now point to the folder and it appears ok. But when I go to save an audio file from Audadity as MP4a with the tags filled in it says: Properly configured FFmpeg is required to proceed. Maybe there is some incompatibality betweeen Audadity 5.0.1 and FFmpeg 0.6.2. Or more likely I haven’t done this correctly? Any guidance welcome it would be great to save files in the M4a format aimed towards my IPad etc… Next step to add Album artwork!? I just love Audacity. We use it at church to record the sermons etc…

There is no such thing as Audacity 5.0.1.
To check the Audacity version, look in “Help > About Audacity”.
The current version of Audacity is 2.0.5 and it is available here:

Oop type - Yes it is Audacity 2.0.5 on Windows 7 Prof SP1 64 bit. Hopes that clarifies the type on my part! But I still would like to know why I cannot install FFmpeg as an add on and get it to work.

Open: “Edit > Preferences > Libraries”
What does it say in the FFmpeg section?

I have put the FFmpeg files in a Library in my /user-name/ directory (no problems with permissions). Dir called: FFmpeg_v0.6.2_for_Audacity_on_Windows. This directory holds: 04/04/2011 10:07 6,682,635 avcodec-52.dll; 04/04/2011 10:07 943,345 avformat-52.dll; 04/04/2011 10:07 112,791 avutil-50.dll; 04/04/2011 10:07 117,248 ffmpeg.exe; 4/04/2011 10:07 35,821 gpl-v3.txt; 04/04/2011 10:07 231,595 swscale-0.dll; I go to Preference > Library and point to the Fmpeg_v0.6.2_for_Audacity_on_Windows directory. It doesn’t give any error message at this point. I then load an audio file into Audacity. But when I go to export it to MP4a it says: ‘Properly Configured FFmpeg is required to proceed. You can configure it at Preference > Library’. So it appears to me that it hasn’t picked up the FFmpeg library when I add it, even though it doesn’t give an error message at this linking stage. Hope that clarifies what I am doing. I think it was what the instructions for FFmpeg said on the Interent.

The instructions are at .

The files you list appear to be correct, but as Steve asked, when you go Edit > Preferences, choose “Libraries” then look at “FFmpeg Library Version”, what does it say to right of that? Does it give F, C and U numbers or does it say “Library not found”?

If it says “not found”, press Locate…, then Browse…, then select and open the copy of “avformat-52.dll” you mentioned.

If there are still problems, open Help > Show Log…, then save and attach the log. Please see here for how to attach files: .


When I point to the directory FFmpeg that contains the files. Select and open etc… It says above the Locate button: FFmpeg Library Version: FFmpeg library not found. I have tried pointing to the folder FFmpeg (I simplied the long folder name) or even pointing to the contents of the file and say all file types. But what ever I do I don’t seem to be loading the FFmpeg Add On to the library of Audacity. Sorry I have tried to follow the proceedure.

You don’t select and open “etc…” you select and open explicitly “avformat-52.dll”".

If that doesn’t work, please attach the Log as requested. Or at least, press “Locate…”, then in the “Locate FFmpeg” dialogue that appears, tell us what it says in the " Location of ‘avformat-52.dll’: " text box. You can right-click over the text for that location, then Copy, then Paste that location into your reply.


Yes, great I pointed to the specific file and it loaded the library. And now I can export as MP4a - great. Sorry I didn’t quite catch that I was pointing to a specific file. Next step to see if I can include album artwork in producing MP4a audio for my Apple/IPad approach. But thanks for your excellent work. I do indeed thank God for forums

Audacity does not currently support embedded album artwork. You will need to use a third party application to attach the artwork after exporting from Audacity.

I’ll add your “vote” that Audacity supports this at some future time.

You can add artwork in iTunes. This isn’t always intuitive but if you have problems this topic may help: .