Cannot select headphone for playback on MacBook Pro 15" 2018

Hello Audacity Support,

I recently purchased a new MacBook Pro 15" 2018, since this purchase I can no longer select my headphone for editing playback, I have tried the lates three versions of Audacity, 2.1.2, 2.1.3 and 2.2.2, I have also tried Mac OS 10.13.6 and also tried upgrading to 10.14.

Do you have a fix for this?

thank you,


tried upgrading to 10.14.

I probably wouldn’t do that. 10.14 has ratty support for 32-bit applications and Audacity is a 32-bit app. You may have improved your self out of an audio editor.

Apple (upper left) > System Preferences > Sound > Output.

Screen Shot 2018-09-28 at 21.11.27.png

This exact machine is old and it may not say that any more. Does your MBP gave an actual round headphone connection or one of those new-fangled Apple data connections?


I have no problem running Audacity 2.3.0 on my 2017 Macbook Air running 10.4.1.
– Bill

I have no problem running Audacity 2.3.0 on my 2017 Macbook Air running 10.4.1.

We had a posting where the Audacity install didn’t act predictably after the upgrade. I suppose it could depend on the environment. I know SoundFlower fails. I understand SoundFlower has been taken over by an active developer. That’s on my 2-Do list.

In any event, switching to a questionable operating system to diagnose a problem may not be the best idea. That’s a good way to kill yourself with two problems instead of one.


Ok thank you to everyone that got involved in the discussion

  1. Yes this is a new MacBook Pro 2018, Yes it still has a physical mini headphone jack.
  2. I did not upgrade my Audacity or my Mac OS until I noticed the problem to hopefully fix the issue.
  3. Audacity is not recognizing the normal setting of “Built-in Line In” in the preference tab, yet its still an option within Mac preferences.
  4. I have tested this in 4 different versions of Mac OS as well as Audacity the recent 2.3, there is definitely something different that requires addressing in Audacity.

Here is a screen shot
Screen Shot 2018-10-01 at 3.59.10 PM.jpg

Could you post a screen shot showing System Preferences > Sound > Input with “Built-in Line In” selected?

After you have made that selection in System Preferences, start Audacity (if Audacity is already running, do Transport > Rescan Audio Devices) then go to Preferences > Devices and see if you can select “Line In” as the input device.

– Bill

I want to see that, too.

There are only two versions of Stereo Line-In. On the larger and older MacBook Pros (and current Mini) , it looked like this.

The only other option is the 13" MBP which only had room for one hole. You could do both jobs one at a time and you had to manually switch in System Preferences.

I know of no other stereo input connection. If it doesn’t appear in System Preferences > Sound, it very likely doesn’t exist. I intentionally bought a new, but slightly older model MBP so I could have that connection.


There is another way to mess this up. Go > Utilities > Audio MIDI Setup. Problems with that are pretty rare and I keep forgetting it’s back there. With some digital interfaces, it basically goes on vacation and all the settings freeze.


I’m exhuming this thread because I am having the exact same issues with Audacity on my MacBook Pro.

I have a MacBook Pro 15" from 2018. It’s running Mojave OS.

I’m using Audacity 3.0.2.

My issue is the same as described by the OP: I’m stuck using my external speakers to edit my audio files because using my external headphones are simply NOT an option I can figure out how to use. I need to edit my fiance’s audio file and we came to a loud coffee shop to do it, which would be totally fine if I was able to do something as bottom line normal as edit sound using headphones.

Can anyone help me out here? She’s on a tight deadline to get this work done and I want to stay engaged to her. :slight_smile:

How are you connecting the external speakers? What headphones are you trying to use and how are you connecting them?
– Bill

I’m trying to use simple Apple earbuds that fit into the headphone jack. And as it turns out, I just now Googled another source that provided a fix:

Audacity: Transport > Rescan Audio Devices.

That found my headphones where everything else failed.

Had similar problem, helped this solution -

This is the answer I’ve been looking for as I couldn’t select headphones. Thanks so much for posting this - I was getting really frustrated!