Cannot record with Audacity Win 10, Toshiba Sat [SOLVED]

I am posting this because I have solved the problem, but found nothing posted in multiple forums that solved the problem. I am trying to record the audio played during when streaming YouTube videos. Here is what I did.

On the Toshiba Satellite S55 the only audio driver is Conexant SmartAudio. There is no Stereo Mix option that I had on Windows 7. Suggestions I saw involved many steps and some were outdated. I tried some things but never got close. For example a common solution was to right-click the Speaker Icon in the system tray and under recording devices right-click and check show disabled devices. That did solve my problem. I only had one option, Conextant SmartAudio micrphone array.

I called Toshiba tech support and was on the phone with them for nearly an hour. Once the tech understood what I was trying to do he said he thought he knew how to fix the problem.He tried to sell me the solution for $150-100 (depending on the option). I had to pass. The supervisor came on the line and tried to sweeten the deal. Geez.

So figured then is must not be that hard.

I went back to the audacity console (v2.1.1). For audio host I chose Windows WASAPI. Under the microphone options I had two selections - Microphone Array (Conexant SmartAudio) and Speakers (Conexant SmartAudio) . I chose Speakers and Wasapi on a whim. Budda-bing, budda-boom that worked. I could not believe how easy that was.

So I hope this helps my fellow schmucks.

Marked as SOLVED.

Glad it worked out for you tblackburn54
For completeness, here’s the instructions in the manual: