Cannot record silence

Using Audacity V 2.3.1 on Windows 10.

Prior to about a week ago, silence at the beginning or in the middle of a recording worked perfectly for me. I could start recording, record silence as long as I wanted, and then start recording sound from for instance a web site. And I could pause the source, and the silence would record for as long as I remained paused.

Starting a week ago or so, the recording will not start until sound is provided from the source. And if I pause the source, the recording will pause after about 1/2 of a second.

I need to have things as they were! I need my silence back!

I have tried all the Audacity settings stuff I can find, including “File / Preferences / Recording” where everything is unchecked, including Sound Activated Recording. And using editing tricks like cutting out sound, or pasting silence into a track will not meet my needs.

It used to be so simple and so perfect. What went wrong? Same hardware, Same operating system, same Audacity version (I even tried 2.3.3 today), same device drivers, same source, same everything; but things are not behaving the same!

Any help would be greatly appreciated. :slight_smile:

Dale Pickles

If you are recording streaming audio with WASAPI (loopback) that’s a known issue where it Windows won’t record when there is no “audio stream”. (It will record if there is a silent stream.)

Otherwise, mske aure [u]Sound Activated Recording[/u] is not enabled.

Thanks, DVDdoug.

But things sure were different, and happier, for me up until about a week ago. How do you explain that?

Dale Pickles

But things sure were different, and happier, for me up until about a week ago. How do you explain that?

Sure… [u]Code rot[/u]! :smiley: :smiley: :smiley:

If it’s a loopback issue that’s not new but maybe there was a silent stream or something else “playing” silent (or nearly silent) audio at the same time.

I think the Audacity developers could make a work-around with an option to “play silence”, hopefully without too much additional demand on the system. You could probably accomplish the the same thing by playing a silent file in Windows Media Player but if that ends-up hogging too much CPU time you could get recording glitches.

If your soundcard/drivers have give you a “Stereo Mix” or “What-U-Hear” option, that’s similar to WASAPI loopback and it won’t stop on silence.

I am not sure this will be of any help, but you could record the sound from One minute of silence. It does work with WASAPI in Windows 10 and latest Audacity.

I’m just trying to understand why things were one way for me for several years, and then suddenly got different. The change is a negative one for me.

I just want to somehow get things back to the way they were a few days ago… when I clicked the red Record button, the track started recording regardless of all other things; and now that is not the case.


Go into the Windows Sound settings and select the recording device that you are using. For that device, enable the option “Listen to this device”.

why things were one way for me for several years, and then suddenly got different.

Windows 10 update? Windows has made it so you can’t opt out of their updates. There have been some nasty surprises as Microsoft closed parts of the system off from evil software, viruses and break-ins.

I could start recording, record silence as long as I wanted, and then start recording sound from for instance a web site.

You were fine until you said “from a web site.” Now you’re playing by Microsoft’s rules. Audacity doesn’t get sound from a source or thing. It gets it from Windows. Recording from a web site involves running Record and Playback services at the same time and connecting them. That’s a special order.

enable the option “Listen to this device”.

Did that work?


Windows 10 with all currently available updates.
Audacity 2.3.3, using Windows WASAPI as Audio Host, and “Speakers” as both Recording Device (loopback) and Playback Device.
If, for example, I go to CALM RADIO - Haydn, recording in Audacity won’t start until I have clicked the Play button on the Web site.
If I pause play on the Web site, recording carries on in Audacity, and it records… silence (flat line) for as long as I wish.
Now if I stop recording in Audacity and undo the first recording that was made, I can press the Record New Track button, and Audacity will record silence for as long as I wish. If I relaunch Play on the Web site, Audacity records whatever is being played there. If I pause Play on the Web site, Audacity carries on recording silence for as long as I wish. Etc.
So it seems that a first recording needs to be made, then undone, before silence can be recorded at will.

WASAPI works differently from MME or directsound.
When recording with WASAPI, there has to be an active audio stream for Audacity to record. If there is no active audio stream, then Audacity will just sit there waiting for an audio stream to start. You can’t count sheep if there are no sheep, and WASAPI can’t record an audio stream if there is no audio stream.

What I tried to say is that WASAPI (Audacity) does record audio stream when there is none coming from the audio source (when the Web radio stream is paused). In such a case, WASAPI (Audacity) does count sheep when there are no sheep in the Web page pen: it records silence.
It also records silence before the Web radio stream is unpaused if there has been a previous recording, and it has been undone (Edit > Undo).

As long as the audio stream is running, Audacity can record it, even if it’s a stream of zeros (absolute silence). When there is no audio stream (not even zeros), then there’s nothing to record and Audacity will wait (after exhausting buffered data) for the next audio sample.

This is an easy way to ensure there is always an active audio stream.

OK. Understood.
But “Listen to this (recording) device” is of no use with WASAPI because WASAPI has no real recording device: it uses the Speakers or the Headset in a loopback.
As far as my system is concerned, I could never make MME or DirectSound work to record streaming audio.
WASAPI works flawlessly.
Now I just tried this:
I started an audio stream in a tab in Firefox. I paused it. I was able to record silence in Audacity.
I kept the first audio stream paused in the first tab, but I started a different audio stream in a second tab still in Firefox. Audacity started recording the new audio stream and ignored the silence coming from the stream paused in the first tab.
So it is possible to record silence and actual sound alternately switching from one audio stream to the other.

When using WASAPI loopback, if “any” device is being listened to, there should be an active audio stream. To avoid noise in the recording, turn down the recording level of that device.

Both my Speakers and Headset are being “listened to” in the Windows Sound panel. This is permanent. I use the Sound icon in the Notification Area to switch from Speakers to Headset and back at will.
I don’t see how it is possible to “turn down the recording level” of the Speakers or Headset in Audacity. The WASAPI recording level seems to be self-adjusting and is not linked to the actual listening level in the Speakers.
Anyway, I can record silence by pausing an audio stream, and go on recording an unpaused different audio stream if I switch to a different tab and audio source.
This was the OP’s aim.

Maybe I’m going daffy (quite possible) but it seems that until a week ago or so I could simply (1) Boot up my PC, then (2) launch Audacity, then (3) click the red Record button, and Audacity would record silence until I clicked the stop button.

And starting a week ago, Number (3) above does nothing until I start pushing sound out my speakers from whatever app or website.

So tonight I figured out a work-around based on a few suggestions in this thread… I found a “video” on YouTube that does a silent countdown from 8 hours to zero ( As long as that YouTube video is running, Audacity behaves for me like it used to behave.

Thanks to all who responded. I’m still a bit confused, but case closed!!

D. P.

It happened to me as well , recently i had to do a scan for hardware changes and since then i could not record silence , but i accidentally found a workaroud , if you get into a discord call by yourself audacity will record the silence that is picking up from the discord call .