Cannot record second track

I have been using audacity for about 2 years now.
I haven’t recorded for a while but the setup is same as when it used to work.
The issue is, after I record the first track, I cannot record the second track.
It stops almost instantly. Recorded legnth tells me it is about 11ms.
My setup is dynabook gx83 (core i5 8th gen so should be no problem), M-Track Duo from M-Audio, with a AT2020 mic and headphones attatched to the interface.

I have tried rebooting, changing sample rate to both 48000 and 44100.
I downgraded to 2.4.2 but this didn’t work either.
This topic seems to have the same issue

Any help will be appreciated.

A lot of users have reported difficulties with these devices. Search the forum for M-Track or M-Audio.

You may be on to something here. Be sure to change not only Audacity’s Project Sample Rate, but the rate for both Playback and Recording Device in the Windows Sound Control Panel:

[Windows-Key]-R, “mmsys.cpl”


Then select your Playback Device:


Properites > Advanced Tab > Default Format


Repeat for both Recording and Playback Devices. If 48000 doesn’t work, try 44100.

Thanks for the response!
I retried on changing the sample rate to both frequencies in 32bit, both on audacity and windows settings.
Doesn’t seem to work. Attempt on version 2.4.2.

Will look into other entries on the forum.

Now have a wierd symptom.
I have both audacity and windows settings set to 44100 Hz 32bit. All other devices disabled in windows sound settings.
After I try recording on Audcity, first track records fine and attempting on the second track gives me the error “Error opening recording device. Error code: -9997 Invalid sample rate.”
After that when I look into the speakers settings in windows, the sample rate is switched to 48000Hz 32bit.
Seems like Audacity is rewritting the windows settings, but could this happen?

PS after tweeking around windows, a found that in the sound settings panel, when you set the speakers settings to 44100Hz, then open the recording device panel, the speakers settings changes back to 48000Hz.
I guess the root of the cause is windows… how could I fix this?

Doing the same with 48000Hz only gives me the “click” record and immidiate stop of record on second track.

Update on issue!

I uninstalled Audacity version 2.4.2. Installed 3.3.3 with preferences reset.
Set the sampling rate to 48000Hz since windows doesn’t let me use 44100Hz for the speakers.
In the “Host Settings”, MME and WASAPI didn’t work, but DirectSound worked perfectly!

Other settings doesn’t work but at least I can do what I want, so I’m good now.
Thanks for the support!

Thanks for the update. :grinning:

Update again on the issue!
The problem was that after recording the first track, recording on a second track gives me an error.
Recording twice on the same first track is fine.

In the previous reply I solved this by setting all the sample rates to 48000Hz.
This seemed to work on screen, but when I did some musical stuff I noticed it was out of tune.
Seems like the mic is picking it up in 44100Hz and the system is processing it as 48000Hz so the music gets unharmonized.

So again I was tweeking around the settings and found out the solution below.

  1. Set all settings (both windows and audacity sample rates) to 44100Hz.
  2. Record first track.
  3. In windows settings, “Playback > Speaker” the sample rate gets switched to 48000Hz some how, so choose 44100Hz.
  4. Record on second track.

Every time when you add a track, if it gives you an error, check the windows settings.
It changes somehow so overwrite it with the correct value and should work like a charm!
Hopes this helps others.

Also, as I said before, “Be sure to change … Audacity’s Project Sample Rate”. Perhaps I was not clear. This is under Audio Setup > Audio Settings > Quality > Project Sample Rate.

I did.

I don’t know either windows or audacity is the cause, but after I try recording on the second track for the first time after a fresh launch, the windows settings get overwritten somehow.

Anyways, I’m able to produce music and happy!
Thanks again for the support!

This topic was automatically closed after 30 days. New replies are no longer allowed.