Cannot Record in Stereo

Both recording channels are duplicate mono and I cannot get them to record in stereo.

Audio Host - MME, other options available are Window DirectSound and Windows WASAPI
Recording Device - Microphone (3-USB Audio-CODEC), other options are Microsoft Sound Mapper Input
Recording Channels - 2 (Stereo) Recording Channels, other options 1 (mono) recording channel
Playback Device - Speaker/Headphones (Realtek), other options are Microsoft Sound Mapper Ouput and Speaker (3-USB Audio Codec)

I have gone into ‘Sound Settings’. Input and Output are as described above for Recording and Playback Device. Below both input and output are the statements ‘Some apps are using custom (input/output, respectively) settings. You can personalize these in app volume and device preferences below’

For device input properties I can get the Microphone Properties. In the advanced tab the default properties are ‘1 channel, 16 bit, 44100 Hz (CD Quality)’. I then select ‘2 channel, 16 bit, 44100 Hz (CD Quality)’ both Exclusive Mode boxes are checked and then hit ‘apply’. I get the following message: 'Device in Use - The device is being used by another application. If you continue, that application may stop working. Do you want to continue? I select ‘yes’ and message window closes, Microphone Properties window also closes. When I go back to the properties, the ‘1 channel, 16 bit, 44100 Hz (CD Quality)’ selection remains.

Under the App Volume and Device Preferences I have ‘Master Volume’, ‘Output and Input’ selections as in Audacity. Under Apps I have System Sounds, Audacity, and System Sounds (folder).

How can I get actual stereo input to Audacity?


Recording Device - Microphone (3-USB Audio-CODEC),

Are you recording from a USB microphone? Is it a stereo microphone?

…Most microphones are mono, so if you have a stereo mic you’d know it and you probably would have mentioned the make & model number. Usually when you record in stereo you use two (or more mics) but with USB, you can only use one mic/device at a time.

USB services in general are not mixers. You can’t decide you’re going to record with directional left/right placement if the microphone or driver software doesn’t support it.

It fails the other way, too. If you have a stereo microphone system it can be an uphill fight to get a mono (for example) audiobook reading out of it.

It has to say “stereo microphone” on the box—and those are a little odd. Most microphones are mono and can’t tell where left and right the sound is coming from.

What is the model number, INFO or web page?


The recording device is a USB turntable, Pyle Pro PLTTB3U, not an actual microphone per-say. The ‘Microphone (3-USB Audio-CODEC)’ label is assigned by Windows.

I upgraded to a new PC with Windows 10. I had previously been using a PC with Vista, Audacity 2.1.2 and the same turntable with no issues.

OK, the obvious question - Is it a stereo record?


Try the Vocal Remover Effect (with the default settings).

If both channels are digitally-identical you’ll get dead silence. If that happens, I’m guessing your turntable is defective… When Windows (the drivers) make mono they usually give you one mono channel, not two identical channels… So, I don’t think it’s a problem with the computer settings.

If you have a mono record you’ll probably have some small remaining signal, but the vinyl crackle (which is random and different in both channels) will remain.

If you have normal stereo, the center-channel lead vocals will be removed or greatly reduced, as well as the bass and everything else in the center but there will be quite a bit of remaining sound.

You can also try plugging the analog outputs into your stereo (or your TV) to check if you’re hearing stereo. If you get stereo and if you have a desktop/tower computer with a regular soundcard, you can record through the line-input on your soundcard (color-coded blue).

Thanks for responding.

Tried 4 different LPs, all stereo. Applying the Vocal Remover Effect does provide dead silence.

The turntable is fine as I can still record in stereo on my Vista PC, I can clearly see the stereo effect in the waveforms.

I do believe the issue can be traced to the inability to select ‘2 channel, 16 bit, 44100 Hz (CD Quality)’ in the microphone properties. It remains in the ‘1 channel, 16 bit, 44100 Hz (CD Quality)’ mode no matter what I do. If this property remains in the 1 channel mode - there is no way it can be in stereo. On the Vista PC I can freely select between the 1 and 2 channel options.

:smiling_imp: Have you tried throwing your computer down the stairs? :smiling_imp:

…I’m out of ideas.

I do believe the issue can be traced to the inability to select ‘2 channel, 16 bit, 44100 Hz (CD Quality)’ in the microphone properties. It remains in the ‘1 channel, 16 bit, 44100 Hz (CD Quality)’ mode no matter what I do. If this property remains in the 1 channel mode

Thanks for repeating that… I kind’ got distracted with Exclusive Mode, which I wasn’t worried about. :blush:

If I understood you, you were not able to select Exclusive Mode, right? That’s OK… Excusive Mode is more “picky” about the settings so it’s better if you don’t use it, at least for now while you’re troubleshooting. (And, I think Exclusive Mode only applies to WASAPI.)

This seems like a driver problem but the strange thing is, virtually all USB turntables use the Microsoft-supplied drivers and those drivers work for (almost) everybody else.

The other strange thing is that you’re getting two duplicate channels instead of one mono channel. (I wonder if you getting duplicates of the left or right channel, or a mono-mix of both channels… But I just wonder… It wouldn’t help me to know…)

Did you try WASAPI or DirectSound? WASAPI is the “latest and greatest” protocol and MME is the oldest.