cannot load GSnap, even 32bit version [SOLVED]

Hi there,
get this error while activating gsnap:

Effect or Command failed to register /home/me/.audacity-data/Plug-Ins/ Could not load the library

Despite knowing some people solved this just installing the 32bit version of gsnap (running windows), this recipe didn’t work on my linux distro.
Tryied both versions with exact same result.
Also tryied chown’ing the plugin to root, with no luck.

my linux distro:

Distributor ID: LinuxMint 64bits.
Description: Linux Mint 19.1 Tessa
Release: 19.1
Codename: tessa

installed audacity (as snap package):

Commit Id:
ff5003 of Tue Apr 13 20:53:40 2021 +0100
Tipo de compilación:
CMake Compilación de distribución (nivel de debug 1), 64 bits
GCC 7.5.0 (Audacity)
Prefijo de instalación:

I’ll appreciate If somebody can help me to solve this issue.
Thanks in advance.

I don’t use VST effects on Linux, but Snap packages frequently disable the ability to load external components.

thanks Steve.
Knowing snap packages could be the problem I’ve installed a apt version of audacity, which can load the plugin with no hassle, but it have a terribly buggy user interface (when record any sound the wavefrom doesn’t display showing just an empty track despite sound is there, and buttons seems to be displaced coz doesn’t respond to ckicks), so I re-installed the snap version, which at least is more usable.

I someone else has experienced one of this problems please let me know if found any fix.

Have you tried the Audacity 3.0.4 AppImage?
It “may” have the same problem with GSnap as the Snap version, but worth a try.

A couple of issues that I’m aware of with the AppImage:

  1. Selecting any language other than English does not work from the Preference settings (there’s a workaround if you need another language).
  2. It does not support Jack Audio System (but most people use ALSA)

You can download audacity-linux-3.0.4-x86_64.AppImage here:

If you’ve not used an AppImage before, all you need to do is to download it somewhere convenient, make the file executable, then double click the file to run it.

how did I forget about appimages!
yes, I do have several of those packages … just didn’t have in mind’em as an alternative.

and … yes! it’s working … including that gsnap plug-in!! :smiley: :smiley:
Just for the record (if someone else is messing around with this pkg) I’ve installed the plug-in right on /usr/share/audacity/plug-ins/ which was created I think during the previous apt pkg installation. …now I’m figuring out how to use such plug-in :nerd:

so, thanks a lot steve!! just saved my (artistic) life :laughing:
(dont know if have ~ nor even how to tag this issue as solved)

Closed as solved :slight_smile: