Cannot Install FFMPEG

I recently updated Audacity to version 2.4.2 and I haven’t found any problems with the LAME library but I’ve been trying to install the FFMPEG libraries and I can’t do it. I downloaded them from the provided website but I can’t make it work. The installation window doesn’t prompt and when I try to look for it in the preferences, it doesn’t show the .dll archive I need.

I’m using Windows 10 x64 and it’s the first time I encounter an error like this.

Did you download ffmpeg-win-2.2.2.exe? Did you double-click to run & install it?

I haven’t found any problems with the LAME library

LAME is now built-in so there is no need to download or install it.

I downloaded that zip, then I unzipped it and double clicked the .exe file; a black window appears for a second and then nothing. I checked if I had a previous version installed but nothing came up. I tried to download it again but I got the same result.

I’ve never tried the Zip file but ffmpeg.exe is not an “installer”. It’s just part of the package.

Try going to Edit → Preferences → Libraries → Locate and browse to folder with the unzipped files.

If that doesn’t work, try downloading and running ffmpeg-win-2.2.2.exe which should automatically install it.

I just tried with the .exe file and it worked.

Thanks for the quick answer. I was struggling with this for a few weeks and I tried everything I had in mind.

I’m not typically one to rez old threads, but this was my top search result for the phrase “audacity can’t install ffmpeg”, so hopefully posting here will help someone else in the future.

I am unable to install FFMPEG on Audacity 2.4.2 running on Windows 10 version 20H2. Here are the steps I took, and the problem encountered:

• Audacity Preferences: Libraries → FFmpeg Library → Clicked Download link.
• Clicked the link: “FFmpeg installation section”
• Clicked the link: “Installing the FFmpeg Import/Export Library on Windows”
• Clicked the link: “FFmpeg download page.”
• Downloaded by clicking the link “FFmpeg RECOMMENDED ZIP OPTION:” (WHY SO MANY STEPS?! 0_0)
• Opened
• Extracted avformat-55.dll to C:\Program Files (x86)\Audacity
• Audacity: Preferences: Libraries → FFmpeg Library → Clicked Locate button
• Browsed to C:\Program Files (x86)\Audacity
• Observed that avformat-55.dll was not found when “Files of type” dropdown was set to “Only avformat.dll”
• Switched “Files of type” dropdown to “All files”.
• Selected avformat-55.dll and clicked “Open”
• Clicked OK
• Clicked OK
• Observed being unable to import .m4a and some .wav files with an error prompting me to install ffmpeg
• Restarted audacity and tried importing again with the same result.
• Relocated avformat-55.dll to a location outside of the program files directory in case access to this file required elevation. and pointed Audacity to the file again.
• Observed still being unable to import .m4a and some .wav files with the same error.

I can’t for the life of me figure out what I might be doing wrong. Please advise.

Part of the problem is that Windows does not allow anchors in links from an application.
The root of the problem is that we have to use a 3rd party download site due to uncertainties over patents / licenses in some countries.

These are the official Audacity instructions for installing FFmpeg:
Note that the recommendation is to use the FFmpeg installer (“ffmpeg-win-2.2.2.exe”) rather than the ZIP. The installer should be easier than the ZIP option.

I did finally figure it out. Like with many problems it’s a bit more obvious in hindsight. So for anyone who stumbles on this later, here ya’ go:

Short answer, you can either use the exe like the above post mentions, or just unzip the entire application because you actually need everything.

Long answer: Why was I silly enough to believe I didn’t need everything and only unzip avformat-55.dll? In the locate FFmpeg dialog box it says “Audacity needs the file ‘avformat-55.dll’ to import and export via FFmpeg”. I assumed this meant it only needed some function contained within that dll. In reality Audacity needs more than that. This is likely obvious to many here, and definitely to those who wrote at bit of text, but it could be more clear. This was compounded by the Zip version being the “recommended” version when I finally got to the actual download link, which reinforced my belief that I didn’t actually need the whole application, which is not without precedent by any means. So, extract the whole archive and you’ll be fine.

Anyway, I’m just happy I got it working. I hope the above is taken as friendly feedback and not as scathing criticism.

Makes sense, thanks.

Had it not been for my misunderstanding I would normally find extracting an archive quicker than a full installation, and is at the least preferable to me personally as I like portable applications. However, I think recommending the exe is generally better advice.

@Drexl - I had high hopes that your post might solve this infuriating puzzle! Like you, I have tried all the steps… but I have also done the .exe and have the whole package installed. Tried putting it in both Program Files and Program Files (x86). No dice any of these ways, still doesn’t see it.

Anybody else have any more ideas to try? I’m kinda at my wits’ end at the moment.

Are you running Audacity 3.0.4, 64-bit? The new 64-bit version requires a different FFmpeg than the 32-bit version.

I have AudacityPortable (3.0.3) installed on a flash drive, and am trying to also get FFmpeg to work. I downloaded and extracted all the files to D:\AudacityPortable\App\FFMPeg. I then went through Edit>Preferences>Libary>Locate, and selected D:\AudacityPortable\App\FFMPeg\avformat-55.dll. After that, I’m still getting the same error as before (“FFmpeg not found etc.”) when trying to import a .m4a file recorded with the Windows Voice Recorder App.

Any ideas? I tried everything people mentioned above. I’m running on Windows 10 Enterprise.

Add me to the list. Have tried everything mentioned above and even a few creative ideas. The installation by either the exe or zip files create C:\Program Files\FFmpeg For Audacity folder with all the contents with the drivers supposedly installed, but the Audacity player will not permit mp4 files to be loaded. Therefore, must still use an online mp4 to mp3 converter, then load the desired file into the player.

Audacity is actually pretty simple to install, use, and works well. Have been using audacity for years without incident. Issue with loading mp4 files started after updating to Audacity 3.1.3

Have Audacity installed on Microsoft Windows 10 Pro. Audacity installed on Ubuntu works fine.


SS 1

SS 2

SS 3

SS 4